Extension load error on restart

Hi everyone. I have installed several extensions with success. However, yesterday I tried installing Curic Align v. 1.6.9. I’m using Sketchup Make 2017. After installation when I restart Sketchup, I get the following error message. I’ve tried uninstalling and installing a prior version of the plugin with the same results. According to Curic, SU 2017 is compatible with the extension. Any toughts?

Error: #<NameError: uninitialized constant CURIC::ALIGN::TextVerticalAlignCenter>
c:/users/charlie/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/curic_align/loader.rbe:118:in <module:ALIGN>' c:/users/charlie/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/curic_align/loader.rbe:89:in module:CURIC
c:/users/charlie/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/curic_align/loader.rbe:82:in <main>' C:/Program Files/SketchUp/SketchUp 2017/Tools/extensions.rb:197:in eval’
C:/Program Files/SketchUp/SketchUp 2017/Tools/extensions.rb:197:in require' C:/Program Files/SketchUp/SketchUp 2017/Tools/extensions.rb:197:in load’
C:/Users/Charlie/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/curic_align.rb:21:in register_extension' C:/Users/Charlie/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/curic_align.rb:21:in module:ALIGN
C:/Users/Charlie/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/curic_align.rb:4:in <module:CURIC>' C:/Users/Charlie/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/curic_align.rb:3:in <top (required)>’

Did you try contacting the author?

By the way, SketchUp 2017 Make is not the free web version as you indicate in your forum profile. It’s also not 2023.

@curic4su might be asleep right now, time zones and all. but they’ll come around for sure. eventually :slight_smile:

1 Like

I haven’t contacted the author yet. I realize web version is not SU Make. I use both. I’m referring to the 2017 desktop version regarding this issue. I use 2017 because it allows me to use plugins.

@curic4su Perhaps the scope operator needs to be used to refer to the constant in the top level ObjectSpace, like


if this is the intention in the code.

UPDATE: Ah … I see now that this constant TextVerticalAlignCenter and the vertical alignment was added with the SketchUp 2020.0 release. So, any older SketchUp version will not have this feature.

1 Like

I need to mention, I’m not educated in programing languages; in this case Ruby Script. So I’m not sure how to interpret your response. If others are experiencing similar problems, I would imagine it could be traced back to developer error, but I haven’t encountered that. I’m not quite sure where to go from here. I looked for contact information on the author’s site, but I’m not finding anything outside of ordering.

It’s simple. It was purposefully directed at Curic, no one else as they probably could not edit his code anyway.

Thank you Dan.


It appears that the issue you’re encountering is related to a version compatibility problem. The error message is linked to a newer API that might not be available in SketchUp Make 2017. I appreciate your patience as I work to modify the plugin to ensure compatibility with SU 2017.

Thank you for bringing this to my attention, and I’m grateful to everyone who mentioned me in the post. I will update you as soon as the adjustments are made to support SketchUp Make 2017 without this error.

Best regards!

1 Like

Thank you for your personal attention to this. I look forward to hearing back from you again.

the same error on my Mac (su 2019). Tried 1.6.6-1.6.9. Could you publish an older version please?

Ah … I see now that this constant TextVerticalAlignCenter and the vertical alignment was added with the SketchUp 2020.0 release. So, any older SketchUp version will not have this feature.

Update! A surprising new developement on the Curic extension. The other day I decided to give it another go. I reenabled the app only to get the same result….the same error message.

This time I decided to dismiss the message and guess what….? It works perfectly. And now when I close and relaunch SU, the error no longer occurs. I should have tried that before. Well, I’m happy now.