Exporting to Unity from SketchUp creates a lot of unwanted triangles

Hey, I am total beginner in modeling and recently I have run into problem. When I am exporting
model into unity, unity triangulates it quite inefficiently. For example I created this simple
model in sketchup :

As you see I tried to triangulate object as best as I can, but in Unity I get different result:

It creates a lot of useless faces, which decreases game performance. Also it creates
lines between different points. I don’t know why it happens because my model in sketchup
is pretty simple, everything is connected into quads and triangles. Can you help me find a solution how to export my object better so it doesn’t create new faces?

Could you upload your actual skp file here (use the seventh icon from left at top of the reply window)? The link you provided is to an image, not the model, and it isn’t possible to diagnose potential subtle problems from the image alone.

project.skp (830.8 KB)

Here it is

you should not create the Tria’s manually if the is what your are doing
In export option window at bottom right you should select those to be compatible with unity, your model also has a number of coplanar edges you could remove. I have not answered unity issues for several years but seem to remember it does not want two sided faces although Su welds vertices for those faces. Have you checked its forum?

You didn’t say exactly how you imported the SketchUp model into Unity, but it is clear that some step of the process involves a surface representation using only triangles (common to many representations). Your rectangular faces all have to be split into triangles in this representation because there is no such thing as a rectangle.

There are some additional problems as well:

In the style, I turned on edge endpoints and extensions before making the attached screenshot. You can see numerous vertices in the middle of or along the edge of (rather than at the corners of ) faces in your model. The export/import triangulation process is noticing these vertices and creating additional triangles as the only way it knows to deal with them. I circled some examples in red on the screenshot. You must either eliminate these vertices or force a particular triangulation by drawing diagonals of your own.

So you are saying that I shouldn’t use “Line” tool because it creates additional vertices and exporting them triangulation process creates new triangles that wasn’t there before and which are connected with those additional vertices?

By the way mac7595 I can’t find compatibility option in the right bottom corner. There is only option button.

No. I am saying that the format through which you are exporting supports only triangles and the exporter therefore must cover every surface with triangles. The exporter is not as intelligent as you would like about which vertices to join when forming the triangles. You can control this by doing more and more careful manual triangulation yourself before exporting.

So I should do this : https://i.gyazo.com/4fa961a333fb702f1781086b90a688fa.png
instead of this : https://gyazo.com/6d9b8d42551793e33b465bf982bffe1d
?
(I am talking about manually triangulating that one chest surface)

And also in conclusion every vertex should be connected with other vertices in the same face with lines?

As an example, yes. That way you assure no additional triangles will be formed there. Your second question would require some testing of the exporter, but probably the answer is also yes, because the exporter is likely to choose those vertices as needing triangles even if all adjacent faces are already triangles.

1 Like

Well thank you for clearing things out for me.

Which format are you exporting to? Some formats only supports triangles.