Exporting to dxf - triangulation problem

triangulation
dxf
cad
export
modeling

#1

I am attempting to export a file to .dxf (originally created in Pro Engineer wildfire 4) from Sketchup Pro 2017. I have 2 issues:

1.Triangulation; the model gets divided into a huge amount of triangles after I export it. When I select the “Merge Coplanar Faces” to reduce the amount, the program crashes. Removing them manually is just taking too long.

  1. The file size is too big. Ideally I would want it to be below 2mb (or below 15MB if any smaller is not possible). It is currently 90MB.

The purpose of this is to provide a downloadable model of the product from a company website which can be downloaded by architects etc. I have seen samples of this without any visible triangulation, in the .dxf format and smaller than 2MB.

Any help would be much appreciated!


#2

Are you trying to export from SketchUp or IMPORT into SketchUp?

If import, bring in the triangulated model without Merge Coplanar Faces. After it is in, select specific elements of the model and use the extension CleanUp to remove coplanar edges in sections… ie dont do the whole model at once.

You will want to inspect the model as well and remove irrelevant parts of the model. Most engineering models are overly detailed for the use as context or entourage. These irrelevant parts, like threaded bolts, nuts, wiring, gearing, etc, tend to be parts that cause the model to be very big.

If you are able, share the dxf with the forum so we can take a deeper look into the issue.

Hope this helps

CD


#3

So I have had this problem too and I can’t believe more people have not brought this up. Maybe I have been using the wrong search terms to find the discussion. Anyway, for anyone who encounters this as it is still an issue, it is a problem to do with the translation of surfaces by SketchUp. The way to overcome it and get perfect exports is to go to Styles and switch off surfaces and also Section Infill. This will give you what you are seeking!


#4

Your post is confusing. If you need a full 3D model in your DXF/DWG export, you have to include the faces. The triangulation is not a SketchUp problem but an AutoCad feature. 3D Faces and polyfaces aree triangulated by nature. SketchUp doesn’t have a “surface” object type (generally “surface” denotes NURBS geometry defined by mathematically correct curves), only flat faces.


#5

Hi And so sorry that I confused you. I should have stated that this was to get a 2D export into HighDesign, an AutoCad alternative on the Mac. I stand by the issue, namely that a straight export of a model with faces produces what are actually grouped lines that describe the faces when exported. When I said that the solution involved switching off faces, it was to select the second from left of the edit options - I don’t know what it is called but it ain’t a coloured or textured face and it ain’t wireframe! it could be of course that this problem connected to HighDesign as the importer. If so, then that would be the relevancy of my post. I hope that clears it up.