SketchUp Export to 3D DXF NOT WORKING

I have the following model:

When I export it to 3D Dxf, it comes off completely warped, and those who try to import it for their own CAD software find it undecipherable. Indeed, when using an online dxf reader, I get the same complaint that they do:

What is going on? This feature clearly is messed up.

It works as designed. Faces are triangulated. 3D software uses triangles to represent faces, on display they are just usually hidden.

.dxf should not necessarily export as triangulated. I suspect the triangulation is already there in your .skp file. Did you import it from somewhere or acquire it, potentially from importing an .stl file which is a triangulated file format? In SketchUp try View>Hidden Geometry to see what’s going on. And, upload your .skp file in a response here to get a diagnosis and a fix.

6 temp.skp (66.8 KB)

Well have at it … I don’t see anything that could result in that triangulation. And I didn’t import anything, this was created from scratch in SketchUp.

You are correct that there is no triangulation in the file, your output was so like classic .stl triangulation that I was fooled. The .dxf output does have triangulated surfaces as a part of the file but they are coplanar and so should be easily resolved in whatever software your colleagues are using. In SketchUp for instance the .dxf importer has a simple check box to Merge Coplanar Faces so the triangulation in the file format is flattened before you see it. Tell your colleagues to merge coplanar faces, a common exercise. Or if they insist on a wireframe view then export a version with only Edges checked in the options box from SketchUp. This will build a edges only version of the geometry that will not have triangulation, they can reskin the boundaries or use it as wireframe for tool paths. Here is a wireframe version to try, but really their software should easily deal with the coplanar triangulation.

6 temp edges.dxf (53.0 KB)