Exporting 2D Graphic - Black bars on image - ACT Settings?

export
modeling
camera
jpeg
advancedcameratools

#1

I am trying to use the Advanced Camera Tools and eventually figure out how to export a 2D Image that isn’t set at a wide aspect ratio… ideally a 4:3 camera ratio. Everytime I add a camera and Export as a JPEG there are black bars across the image. I know this is a recurring topic on here, but is this a confirmed Sketchup Pro 2017 Bug or is there a way to fix this?
I have included the Graphics card detail information, and done the ‘Sketchup Check up’ which all passed and seems fine.
When I remove the Camera and ‘Reset Camera’ and export as a normal view the black rectangles are gone - but I need to export as a 4:3 ratio without skewing the angles.

Any help would be MUCH appreciated!!!

Sketchup Check up Results:

Success: System RAM requirement has been met!
Success: Operating system version requirement has been met!
Success: Graphics card RAM requirement has been met!
Success: Graphics card OpenGL requirement has been met!
Success: Graphics card Hardware Acceleration requirement has been met!
Success: Graphics card capability tests have passed.

Congratulations, your computer has met all the minimum requirements to run SketchUp 2017.
Graphics Card


#2

There’s no need to tangle with the ACT plugin when you can use this instead…

Eneroth Viewport Resizer — Extension Warehouse

When exporting images, be sure to look under the Options button in the Export 2D Graphic dialog.


#3

Thanks for the help… It’s similar to what i’m trying to achieve but evidently exports the image at an even smaller size when resizing? And annoyingly resizes the window altogether.
I’m looking to figure out the solution to the ACT plug ins and export camera views in this way without the black bars appearing.


#5

That’s the whole idea, Jennifer.
You see, SketchUp essentially exports what you see on screen … including the aspect ratio.
Eneroth Viewport Resizer enables you to set the aspect ratio to your desired 4:3


Here, I set it to 1200w x 900h … which is 4:3
Eneroth Viewport Resizer


Once the viewport aspect ratio is set, look under the Options button in the Export 2D Graphic dialog.
There, you can set the size of the image export. while the aspect ratio remains the same.


Below, I set the Export Image Size to 4000w x 3000h
Notice you can change the size, but not the aspect ratio.


#6

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.