SketchUp 2017 Pro - Export 2D Graphic - Black Bars Introduced into Image

export
2d-export

#1

These black lines were not an issue in SketchUp 2016. The camera used to create the views is a Photographic Micro 4/3 Camera with 9mm lens and 27mm lens.

Image Created in SketchUp 2016 and Converted to SketchUp 2017 - Export of 2D Graphic has Black Lines

Image Created in SketchUp 2017. Export of 2D Graphics includes black lines not in original image.

Feels like a bug. I can’t image this would be a feature enabled by default which needs to be disabled to end up with a usable image.


#2

It could be a graphics driver issue - have you tried updating that? Are you writing the file directly to a “cloud” service?

Anssi


#3

This has happened in other version when using Advanced Camera Tools and Printing using Medium or High setting…

on my mac they disappear if I choose Draft or Standard quality for printing…

if I set my viewport ratio to 4:3 and my focal length to 9mm it exports and/or Prints at High quality setting…

I think it’s a bug in the extension…

john


#4

Good advice on graphics drivers. I have a Thinkpad Carbon X1 laptop. It needed lots of firmware updates. I am very impressed with Lenovo’s website and method of updating.

However, after a couple of hours of updating, including new graphics firmware, the problem persist.

I think it is a SketchUp Pro 2017 bug. It worked fine on SketchUp Pro 2016. Same day. Same drawing. The only thing that changed was the SketchUp upgrade.


#5

John,

I tried reducing the 2D Export to 2592-pixels wide from 9999-pixels wide. The black lines are still there, however, witht he reduced resolution, the black lines occupy a larger portion of the image. I also reduced image quality when saving. Problem persist.

The problems we are experiencing sound similar, but are behaving differently. Thank you for your input. Hopefullly the technical support team at Trimble will figure out the source of the problem and correct it .


#6

it did include an all new graphics pipeline, so some graphics glitches are possible…

are they there if you delete the cameras and don’t use Advanced Camera Tools to set the view?

john

that’s the only time I see them…

john


#7

Had to create and account just to post here, there is a fix. I was having the exact same issue, black or in some cases dark gray transparent bars, they were even the same shape as yours.
Someone above mentioned the Advanced camera tool (which installs with sketchup 2017) and even though i had not used it to create any cameras, all of my scene tabs would export a 2D jpeg with those bars on them, all except the default scene 1 tab! Weird huh.
Anyway, go to your scene tabs and then go to Tools -> Advanced Camera Tools -> Reset Camera . Your scene view will adjust a bit, go ahead and just zoom back to where you want it to be and your exports will work fine. Do this to each scene tab, save and you are good to go.
No idea why this is happening, but props to john_drivenupthewall for setting me in the right direction.


#8

il faut réinitialiser la camera et le problème se règle


#9

Hi, For me the problem was V-Ray Tools²by ThomThom extension. To remove bars I just reset aspect ratio in camera view. Looks like it’s not compatible with new sketchup 2017.The black bars show up even on standard sketchup 2d export when in scene the extension was used.


#10

Any solution to this yet? I need the 2D export to work.


#11

there are a number of posts on this topic.

Did you try resetting the aspect ration in the Advanced Camera tools?

If you don’t want it to happen, turn off Advanced Camera tools or Vray.


#12

Thanks for your response.


#13

If you’re using Vray, turn off Safe Frame under Render Output. Solved the problem for us.


#14

I did exactly this, and my problem was solved. I turned of the safe frame.