Exported drawings (DWG) in sketchup layout has black background in Autocad

i would like to have my drawing the way they are displayed in LO. But once it is exported as a dwg in autocad.

  • it has a black background
  • text and lines are not visible

i need my drawings scaled, so inserting as an image is not an option

SketchUp and LO do NOT include a background in an exported ‘geometry’ format file.

However, you can always adjust your AutoCAD settings to use whatever background color you want - change for both the Layout[PaperSpace] and Model…



Tools >> Options >> Display >> Colors.
That way it can appear just as it does in SketchUp/LO.

You can also change the color of the Layer[s] containing the Text/Lines in SketchUp etc - typically Layer0 in SketchUp [becomes Layer ‘0’ in AutoCAD] - so if it’s black in SketchUp consider changing it to ‘gray’.
But again you can use AutoCAD’s Layer Manager and reset the Layer colors there - e.g. to contrast with the background - black/white being the obvious choices…


AutoCAD should be clever enough to spot if the background and Layer 0 are the same - e.g. both ‘black’ and display the Layer color as ‘white’…

Hi TIG, what i meant was the images that came from LO displays with a dark background, even if the settings in autocad was to display white background.

The images in LO displayed with no background, autocad does. Any setting i have to do?

Is that a screen shot from AutoCAD ?
If so then change the Model space settings to have a white background - As I linked to earlier…

If it’s a screen shot from Layout then what are your settings of the viewport[s] ?
Are you exporting the DWG as vector ?

Hi TIG, yes those are screen shots inside Autocad ( exported from LO)

i think i saw a solution for my concern just now. But i’ll still try other options. I think right now i’ll go for this procedure

Thanks TIG