Export for laser cutting

I have some stl files of gears that were sent to me and i am wondering if sketchup can somehow convert them into a file that can bu used with lightburn so i can cut them out of my 6mm plywood i have. Maybe export as a svg or something.

They need to stay the exact size they are. I know they were created with fusion 360 and so the stl (even though its unitless) was saved with correct units so it opens in a slicer the correct size.

wheni try to import ito SU it get this mess

Blade+Rack.stl (6.0 MB)
Smaller Driving Gear.stl (10.1 MB)

I got the same results. The segments of the model are very tiny so I imported them using Meters as the model unit. Still the result was the same. They opened in Rhino OK.

1 Like

Opens in my printer slicer.

1 Like

same, they printed fine for me but SU does nto like them. Somehow i need to get them to my laser cutter TODAY since this is for my active drag system for a rocket for senior project.

Here are your parts as saved from Rhino as SKP. There might be holes due to the very tiny segments.
Blade+Rack.skp (240.1 KB)
Smaller Driving Gear.skp (1.2 MB)

1 Like

Ill try and open them and then convert to something lightburn can use.

Wish there was a better way from sketchup to lightburn

LightBurn is layout, editing, and control software for your laser cutter. With LightBurn you can:

  • Import artwork in a variety of common vector graphic and image formats (including AI, PDF, SVG, DXF, PLT, PNG, JPG, GIF, BMP)

I just tried Julia’s SVG exporter and it seems to be functional -


When you import the STl files into Skethup you’ll need to click on the import option and select a reasonable unit (like inches).

1 Like

I tried inches, mm, meters, and it all goes nuts haha.

These were

  • imported as inches
  • painted Black
  • exported at a ratio of 1:10

gears as SVG.zip (192.2 KB)

how did you get the files open? because no matter what units i choose, it does not work

Oh, that’s interesting. And I notice that Anssi seems to have resorted to Rhino to open the files?

I didn’t expect this detail to be important, but, I used bastardized version of the Sketchup-STL importer from this link.

1 Like