Export a dwg to the correct scale


#1

I’m using SketchUp Pro 2015 and trying to export a very simple 2D drawing to a dwg so it can be read by a cnc cutting machine. I’ve tried all sorts in the options tab including all the versions and putting in my own scale - nothing seems to come out correct when I open the file in Solidworks eDrawing!

The most annoying thing is going back a few months I did manage to work it out but didn’t take note of how I did it, please can someone help?


#2

Create your model to full scale.
If you use the File menu>Export>2D Graphic… method to export to DWG, verify that your view is set to one of the standard views (top, left…) and that your camera is set to Parallel Projection.
Export to full scale. SketchUp uses your current unit settings for the export unit.
When opening the DWG in another application, you may have to set the importing unit “manually” as the file attributes may indicate an export using imperial units even if you use metric (the numbers are correct, though).

Anssi


#3

DXF/DWGs are in general dimensionless, i.e. do not contain information concerning the used unit.

The import in the destination system may lead to scaling effects if the wrong unit was choosen before importing. For fixing this, just do either import again in the correct unit or use a scale tool if avail.