Error When Trying To Log Into Sketchup For Schools

We are a K-12 school district and I am trying to deploy Sketchup for Schools to a group of Chromebooks. The app seems to deploy successfully but, when I try to use it, I get this message: “Sketchup for Schools is only available for students and teachers in primary and secondary education programs.” I cannot get past this point. We have Google Classroom turned on for everyone, which I read needed to be turned on. If anyone has suggestions on how to proceed, it is greatly appreciated. Thank you.

I’m experiencing the same issue trying to deploy the app for our computer science lab. We have G Suite for Education and like you said, Google Classroom is enabled.

I went to and tried to add the app from there and I just get an error :confused: “We are unable to process your request at this time, please try again later.”

Thank you, ssppeaston. That, so far, seems to have worked for me.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.