Error on Component Options window when downloading in window

I have similar issue with dynamic components. I am running Windows 10 x64 and Sketchup Pro.
When I create dynamic component, everything works. But, when I save the file and try modify dynamic component I get error message “No entity data returned” and then "ERROR: Call back function error … "
I found that it has something to do with file location. When saved in Document folder, it works fine.
Any reason why? Thanks.

Check the path name where the file was stored. Top level cannot start with the letter “u”.

My path was C:\usr\emerson\dropbox.
Moving to another path works (c:\temp\usr\emerson\dropbox).

BR / e

Hi, thanks for your reply, but my path looks: e:\xVx\RC\Fiesta WRC 2017\fiesta WRC 2017 - 001.skp
As you can see there is no “u” letter. The problem must be somewhere else.

What happens if you copy the file to another folder (for example e:\temp).
Does it work there?

It doesn’t appear this issue has been addressed yet by the developers. It just started happening to me yesterday (4/19/17). I use SketchUp almost daily, and the only change to my system that I’m aware of since SU was last working properly on my machine is a Windows Update earlier this week.

This issue is definitely related to the directory path, and does not occur for me until I SAVE the file for the first time.

Generally, I save my files on my desktop: C:\Users\user\Desktop, but now I cannot, due to this issue. In my case, the issue is related to the “user” directory. If I save within a differently named user folder, or save a level up (i.e., within C:\Users) I have no problem.

This problem occurs regardless of the SketchUp version I try (15, 16, or 17), and updating or reinstalling the Dynamic Components extension does not resolve the issue.

Anyway, saving my files to a different location is not the end of the world, but on the other hand, such a bizarre issue is really not acceptable either. This really should be an easy fix for the developers.

Hope this was helpful.

Thank you.

if your really using ‘user’ as your user name, then the issue has been discussed before…

the problem arrises due to the \u in the path…

it tells the OS to look for a unicode character which ‘ser’ is not…

so the path fails…

there are a few others…


Yes, but I’ve been using this machine for 4+ years with no issue. And then all of a sudden it was. What changed?

Maybe that Window update?

The code "\x" is also an escape sequence beginning a hexadecimal number value.
Also "\f" is the escape sequence for formfeed.

\a - BELL
\t - TAB
\x - hexadecimal value for character
\o - octal value for character
\u - unicode number for character

1 Like

can you please provide information why this has not been fixed for version 2018 resp. when you will fix this issue… for all escape sequences of course (see above)?

Hi! here to report that it’s a really silly bug and it’s still happening in late september 2019.
I’m astounded to know that such a small glitch is still lurking after years from the initial spotting.

It’s 2020, and this bug still exist. Any suggestions doesn’t help…

It took me a long time to find this thread, please fix this issue.
I can confirm that it still persists in version 2020

forgot about this bizarre issue and just re encountered it. Still persists in newest version of SU

I updated dynamic component version 1.8
and it didn’t work, luckily I saved it and renamed the file as you said, now it works

OOOO MYYY GOOOD . I SOLVED IT. my skp name was named urban. and changed the name with any letter instead of u. I changed it to xurban and it worked. :))) stupid. thank you much!

Way back when, in ms-dos days, Microsoft decided for some reason to use backslash as the separator in file paths, even though it was even then the conventional escape character for special characters in strings. For a long time they got away with it because those special characters were illegal in file paths anyway. But then Unicode became conventional and “\u” signifies the start of a Unicode byte set.

But the stupidest thing is, Microsoft platforms have not used MS-DOS since the retail Windows Millennium release.

Businesses had already been on NT based editions and at the same time many personal users also switched over to NT with the Windows 2000 (NT 4) release. I was one who left MS-DOS based Win98 behind and tried to never look back. (I still had to work on client computers running Win98 for some time afterward.)

Anyway, Network Terminal File System based Windows editions and versions have had the ability to use network style paths with forward slashes for more than 21 years now. There is really no good reason for programmers and applications (including some of the SketchUp API’s path getter methods) to return path strings containing backslashes. And IMO returning path strings with escaped backslashes is also outmoded.

ADD: And MS doesn’t help the situation when even Win10 displays local paths in the File Explorer address bar with backslashes.

It’s Nov 2021 and the issue still exists in SketchUp Pro 2021…

This bug makes what could be an incredible feature of the platform almost worthless for anything other than a novelty. To have to coddle your workflow by avoiding directory names and user names in order to prevent an error is silly. If you share your DC’s with others expecting them to also coddle to the poor programming by SketchUp -well that’s just impossible.

Trimble needs to address and fix this issue, or continue to lose a segment of designers who can’t take this product as a serious work tool.


We have fixed this bug! :slight_smile:

For now we are releasing it as a Dynamic Components patch that is included with installations of FlexTools.
You can also get this patch for free by installing FlexTools ComponentFinder.

You can read all about this fix and a few other DC fixes in our post: DC and WallCutter Bug Fixes.

Side note - after all these years, it took Max (our programmer) about 3 hours to fix it! + a few more hours to figure out how to best Patch the DC extension . . .

I hope it works for everyone. If there are any issues, let us know!