Error message: This does not appear to be a sketchup model

I’ve scrolled through a couple similar posts hoping to find the answer. I’ve been working on a model for a couple months now. I had the latest model open yesterday and then when opening it today I received the error message. I have been using a seagate external drive to transport files between the office and my home laptop (because I love working on the weekend). I now know that saving and opening off the external drive is likely the source of the problem, but I would like to try and recover the most recent work. I’ve tried copying the file onto the desktop and renaming it. I’ve tried opening the backup file the same way and I’ve tried opening the Layout file which is linked to the sketchup file that not opening. All seem to be angry… File attached below. Any thoughts would be much appreciated.

Thanks,
Jeff

Pickens Model 7.26.skp (4.8 MB)

@colin is one of the few that may be able to help you.

Trying now…

If you look at the size of the file, it’s under 5 MB, which would be impressively small a file for a couple of months of work. Unfortunately, large chunks of the file are wiped out.

I will mention the file to colleagues. They won’t be able to recover anything I suspect, but maybe they can get ideas about what happened to the file.

Can you confirm that it was a 2021 format file? I am pretty sure that it was.

Hopefully you have a recent version on your computer at work.

Colin,
The contents of the file Pickens Model 7.26.skp are:

24,576 nul characters,
followed by this pdf version1.5 file Pickens Model 7.26.skp shorter.pdf (760.9 KB)
followed by what looks like 4 1/2 megabytes of random memory contents.
and a sketchup model of {SketchUp Version 21.0.391} a very nice timber cart Pickens Model 7.26 Timber Cart.skp (296.9 KB)

Very strange!

Colin,
5 mb is about right. Light on detail, lots of iterations. Yes it was a 2021 format. I do have autosave on, but I’m getting the same error message when I try to open the skb file. Does sketchup a recovery file that I should look for? Unfortunately, I was working of the external drive… nothing on the desktop at work.
Thanks,
Jeff

The skb file is the backup file. The autosave file is an skp that is buried in a support folder. Looking at the skb would be interesting.

sWilliams,

This is making a bit more sense. Neither of these files are the sketchup model that I’m looking for. Both were files for other jobs that I likely had open at the same time. Could I have some how been closed things down too quickly at the end of the day and scrambled the files while saving? So then the question I guess is were might I find a recovery file?

Colin,

I tried uploading the skb file and it won’t let me. Should I save a copy with and skp extension and upload it?

You could rename the skb as skp, then it may even open ok, and will work as an attachment.

Do you use LayOut at all?

I just copied the skb file to the desktop, and renamed it and changed the extension to skp. That worked… Beyond excited. Next step. Linking the “new” model to the existing layout file. How should I go about switching the file links with the name change?

In the LayOut file, File/Document Setup… References, you can choose the SKP entry and then Relink it to the new version of the file.

Make sure to be keeping backups of your files on your internal drive!

I will try the Layout relinking. It looks like I lost only one of the models. It was the one I was working most of the day that this happened. Do you see and models here behind the curtain or did this get combined with the open pdfs like the other ones? Linked below is the renamed skb copy.

Pickens TF Recovery.skp (457.4 KB)

I thought of one idea. Can you post the LayOut file somewhere, prior to relinking to the new file? It is possible to extract the SKPs from that file.

Here is the layout file, I wasn’t able to open it past the error. If you could even just get it open and resaved, I could go through and relink. I’ve got a lot of call outs already in this layout file that I would have to retype otherwise.

Pickens Architectural Set 9.1.layout (13.4 MB)

There was something strange about your earlier SKP, it seemed to have LayOut like data in it. This LayOut file you gave is a SketchUp file. Somehow I think your SketchUp file became a LayoUt file, and vice versa.

Can you think of anything that could explain how that could have happened?

I have no clue how that could have happened other than rushing my close down process because I needed to get out the door. Where you able to open either in the opposite programs. My biggest time lose is in that layout file lose because of all my specs and call outs.

It may be worth trying a disk repair utility on the drive. Might fix some things that you haven’t discovered yet.