Error every time I launch the web app from Chrome on macOS Catalina - 2019 MacBook Pro

When I launch from Safari, the web app seems to run fine, but when I run from Chrome, crashes on launch every time, and is SUPER slow.

I’m happy to provide any other details too. Is anyone else experiencing this? My computer is a brand new 2019 MacBook Pro.

1 Like

Just to be clear too. I’ve rebooted, cleared cache and cookies, etc. I also tried with my extensions disabled, no change. It was working okay in Safari, as a test, but even that seems broken now too.

Same here, on the 2019 Macbook Pro as well. Occasionally I’ll be able to open a model but it often crashes out at some point after.

1 Like

A colleague in support its seeing this issue too. We’re trying to figure it out, and I found that the error happening is one that there is a Chrome bug report about. Here’s the bug report:

https://bugs.chromium.org/p/chromium/issues/detail?id=881866

Watch the screen recording, go to the test page (which is still live), and see if your memory usage goes up. The recording shows how to open the task manager in Chrome.

Google set it to WontFix because they stopped reproducing the problem at some point.

@Mark

I just checked all of your profiles, and my colleague and all of you are using Catalina. But then so am I, and I haven’t had the problem. But, it could be a factor.

I tried to reproduce the bug you link to, but I am not able too. I’ll keep playing here to see if I can figure out under exactly what condition this occurs. Let me know if there is anything you want me to try, I would be happy to help hunt this one down.

For what it is worth, I pulled my console and profiled the app loading in chrome. I’ll attach the console here for your viewing pleasure. Also, as expected, the CPU just slams to 100% while loading, until it errors. I did get in once, with no errors. However, please note another interesting performance related aspect of my experience. In Safari, when I just start a clean model and draw a line, it is very responsive when I move around the end of the line. In chrome when I do the same, it is very very laggy. I don’t know if this is related or not, but I figured I would share. It would not be usable even if it didn’t error:)

console_log.txt (9.2 KB)

Thanks for calling out this problem. We were able to reproduce this issue on a new MB Pro computer at our office too.

1 Like

Excellent. Good luck, and let me know if you want me to test / verify / collect more data if you need.

Our internal case of this problem was cured by updating to 10.15.2. Can some of you try that too?

Bam! Problem solved. Performance and stability are much better now. As in, it loads with no problem, quickly and drawing a line doesn’t lag. All good. Thanks.