Enter key doesn't work ( + others keys)

Hi,

I know someone asked the same question 8 days ago, but I start a new topic even so.

I use Sketchup free fror years now and I’m used to the (maybe old?) keyboard shortcuts. I’m encountering these problems:

-When I enter dimensions (without first clicking in the window) I can write numbers but it is like the Enter key is inactive. I tried with . and , and ; (even copied the “mouse writing” like 50mm, 25mm) between the numbers but nothing works…

-the R (for squares) and C (for circles) shortcuts aren’t working either. Other shortcuts are working. But maybe I’m used to older versions…

Any help would be very appreciated,

Fred.

Have you tried another browser? Most Web version users prefer Chrome.
Another possibility is a faulty keyboard (stuck alt or ctrl key, for instance) or Windows Sticky Keys.

Or number lock on. Sometimes even caps lock can screw with things.

ShiftLK was blocking the shortcuts.

And, don’t ask me why but Ctrl+Enter works as Enter…You lead me on the path. Thanks!

Hey Fred, I’ve experienced the same issue for the past couple of months, only to discover today that the keyboard comment has already changed in SketchUp 2020 (that I currently use). In the old version, it uses the enter key directly. For example, in Rectangle - 2.5,2.5 - Enter, I instantly got the shape.

Now, I have to change the command symbols,

  1. Full stop key (.) into comma key (,) and
  2. comma key (,) into semicolon key (;).
    For example; Rectangle - 2,5;2,5 - Enter.

Let me know if it solves the problem. See you!

Sounds like a localization change.