Ensuring All Geometry is on Layer0 - Problems

layer0

#1

Hi all,

I’ve been told a few times of a great rule for Sketchup to keep all geometry on Layer0. On my most recent full warehouse model. I’ve been working on keeping that rule.

Upon double checking I realized I have some geometry that does not toggle on/off with Layer0 visibility. If I double click into the groups. It shows everything within on Layer0. Am I missing anything?

Below I show what I think I’m trying to describe. Toggling visibility on Layer0 (to my belief) should make everything disappear. It doesn’t on Warehouse_DockDoors or Warehouse_Floor. Furthermore, when I double click on the respective group, it shows that all geometry within looks to be on Layer0.

Appreciate any and all the help!


#2

You could use TIG’s Default Layer Geometry to move all edges and faces back to Layer 0. Make sure you are leaving Layer 0 active at all times. Set it back there before running the plugin.


#3

So how does this work? I select the groups not acting properly with Layer0 and run the plugin with Layer0 as the active?


#4

Just make Layer 0 active and run the plugin. It’s go through the model and put all the edges and faces back on Layer 0 where they are supposed to be. And then leave Layer 0 active from then on.


#5

I followed the steps you recommended and it seemed like nothing has happened.


#6

Upload the SKP file so we can take a look at it.


#7

Maybe the geometry’s parent container (group or component) has an assigned layer. That is how you are supposed to assign layers in SketchUp.


#8

@Eneroth3 : That’s what I thought I had been directed to do. Group the geometry and assign that group to a layer.


#9

Will look when I get home.


#10

All ‘raw’ geometry - edges and faces - should be assigned Layer0.
You assign other layers to ‘containers’ [groups and component-instances].
By switching these layer ON/OFF you control the visibility of these ‘containers’.

So you should always model geometry with Layer0 set as your current layer.

If you accidentally have made some geometry on other layers, then my
https://forums.sketchup.com/clicks/track?url=https%3A%2F%2Fsketchucation.com%2Fpluginstore%3Fpln%3Ddefault_layer_geometry&post_id=156438&topic_id=43711
tool can correct that geometry’s layer.

My tool also auto-corrects all geometry you create onto have Layer0 - irrespective of the current layer.

When you explode a ‘container’ then SketchUp [perhaps ill-advisedly] assigns the container’s layer to any resultant geometry.
This can be somewhat unhelpful !

My tool has a context-menu tool to reassign selected geometry back onto Layer0 - optionally, it also works on nested geometry in selected containers.

My tool also adds a new context-menu tool to explode a selected container, and then correct any exploded raw geometry to be assigned Layer0…


#11

The geometry is on Layer 0 as it should be now although you still have a layer other than Layer 0 as the active layer. I think the biggest problem now is the weird nesting of groups and components. There are nested components such as your security screen that have no reason to be nested. Other elements seem to have a sort of random structure when you look at them in Outliner. The roll up doors are a case in point The center panel with the holes for the windows is a component that is separate from the rest of the door which is a nested group containing the other panels and the glass and some “metal strip” components that are most certainly overkill. Then there’s a roller on one bottom corner of the door but not on the other.

This stuff could all be fixed but it’ll take time. At least the geometry is back on Layer 0 where you should have had it from the beginning. As for any new models, leave the radio button set to Layer 0 so Layer 0 remains active. Or I’m going to come and take your mouse away from you. :smiley:


#12

I misread the original post. I thought the problem was that things got hidden when a layer other than Layer0 was hidden (which would be the expected behavior if the container is on the hidden layer).

I honestly don’t know how SketchUp is intended to behave when Layer0 is hidden. Layer0 is fundamentally different from “other” Layers as it cannot be deleted or renamed so it is possible hiding it is also different. I like to think of it as no layer rather than a default layer. Since you are supposed to always have Layer0 as the active layer (and numerous users have suggested removing the option to even change active layer) I haven’t much experience with what happens when Layer0 is hidden.


#13

So in this case, when I drag a component in, I’ll want to explode it after I bring it in to break apart the nesting?

Doesn’t this make geometry merge? So in the dock door case I want all the door to be together and some parts attaching to the walls, but if I ever wanted to animate the door up I’d want that accessible. Would this be handled by making a dynamic component with up/down position or grouping it or what?

Sorry for all the scattered questions, just trying to understand.


#14

Maybe.

It would if you explode the components back to raw geometry.

Well, you’d want the sub-components to be in the same wrapper. If you have parts that are going to be attached to the building, make them separate from the rest of the door.

DCs could be a good way to go.


#15

This brings up another piece of guidance that goes along with the one about proper use of Layer0: Never leave edges or faces loose (that is, not enclosed in a Group or Component) unless you know you want them to merge with additional edges and faces you will be drawing right now. Said another way, the moment you have created enough edges and faces to define the basics of something, create a Group or Component from them and then open that collection for edit to add the rest.

If you follow this advice, you will never have problems with unintended merging of geometry.


#16

Be wary of the mouse thief…:flushed::grimacing:


#17

This topic was automatically closed after 91 days. New replies are no longer allowed.