Dynamic component units issue

I try to create a simple dynamic component, which would move on X axes by 90cm.
Component Door has one component inside called Leaf.
I’m using metric mm units and once I create component Sketchup switch units to inches in component attribute window. I switch it back to cm manually.
So here is a problem - once I create and try to move it by 90cm it moves 228,6cm insead (90inches).
It means Sketchup still using inches inside component even if I switched it to cm instead.

Anyone know how to fix it some hack.


When you say

Do you mean that you have one component nested inside another? If so, what happens if you explode the inner component?

Where do you switch to metric? What ‘Model Info > Units’ is set to does not matter.
Upon creating the dynamic component you should switch to cm (somewhere top right in the ‘Component Attributes’ window.
And then in the following fields work with cm

p.s. Why doesn’t it matter? The units setting in ‘Model Info > Units’ is only how dimensions are / will currently be displayed in your modeling space.
What is set in the ‘Component Attributes’ window is what SketchUp uses to handle the input values. Internally that will always be inches but what you set and see may be cm.

Try a redraw: rightclick on the component, Dynamic Components->Redraw

Yes I have model units set as mm before start. But when I create a component it makes it as inches.
The units inside component are changed here

Redraw doesn’t help.

Here is a skp file 2018 is anyone is interested to solve the puzzle :slight_smile:
Dynamic component issue.skp (180.3 KB)

You are correct in that you need to convert inches to cm for some of the DC functions, this is true for CURRENT and FACEAREA as well, though with FACEAREA it does tell you it returns square inches

It is about time these bugs be fixed or a better system created…but it seems the propriety is to re-invent the wheel and put it on the cloud

Either place the conversion or use another intermediate attribute
Dynamic component issue.skp (179.9 KB)