Dynamic Component issue: wooden pillar

dynamic-component

#1

When configuring some dynamic components, sometimes problems occur like this from the GIF and I can not understand why …

Everything seems to be properly configured but some fields in the Dynamic Components window do not show the 400cm or 500cm as they should and other strange numbers appear in that place …

Am I doing something wrong?


#2

How about uploading the component?


#3

X conj. pilar.skp (400.2 KB)

Here you are :grinning:


#4

You have some scaling issues, most of the times this happens when you start testing early.
Set the LenX of both the pillar and the fuse to a fixed length(eg. =500 cm) , then, enter the component and rightclick on the fuse, choose scale definition.
This will put the fuse in the right state.
Remove the constraints on both LenX’s till they are grey (‘empty’ formula) again


#5

Thank you!

I marked your post as “solved” because it actually worked according to the steps you indicated.

The problem is that I do not understand the logic of why this happens, and what would be the point at which I start testing early. How do I avoid this same problem in the future?


#6

Always undo a test , instead of trying to ‘get it right’
That ‘s what I do, when developing. Always return to the state were things did not go haywire…