Dynamic component copies not showing


#1

I just started working with dynamic components today and I’m having trouble figuring out whats wrong with my model. I’ve got a clip rail with the clip spacings defined by the first and last clips and a value for the distance between the 2 outside clips. It fills in the center spacings without going over 5.75". My formulas give me all the right dimensions, but the center clips that are supposed to be copies don’t show up.


#2


#3

I’ve noticed you have placed the model on the warehouse, it does work, Perhaps you are editing the component definition file itself. Open a new template then insert your component from the inbuilt browser (or drag and drop from the folder where it is filed)

It should work

Editing to suit your needs is best done on a definition instance then right click menu to save as a component overwriting the existing


#4

I don’t know, even if I download it from the warehouse and open it in a new instance of Sketchup I still don’t see the copies. Looking at it, the CenterClip has 6 copies under “Behaviors”, and the X position is “=SecondClip!X+ClipRailComponent!CenterSpacing+copy*ClipRailComponent!CenterSpacing”.


#5

Box_Peg.skp (441.8 KB)

Ok, this time I tried it with a super simple dynamic component, just two sub components. In this file I have a box and peg. The peg has Copies =4, and X is =4.5" + copy*4.

I’m still only showing 1 peg, even if I look in the Outliner. I tried reinstalling SketchUp, but this didn’t help. Anything else I can try?


#6

I downloaded it and took a look. I was able to get the pegs to show up. Are you importing your component into a new drawing, or opening the .skp file? I did have to open the attributes, change the copies, and then hit Enter to make them show up.


#7

I made a few change… not sure if this was the issue, but the name of the main component caused some issues for me (Box & Peg), so I renamed it and added a user editable attribute to the main component that the sub-component (the peg) references. when you download it, import it into a new model, then right click and use Component options to edit.

Box_Peg_1.skp (21.6 KB)


#8

Hmm… still can’t see the copies. Could an extension I have installed possibly be causing this?


#9

In this world, there are ONLY possibilities.

When you import and open the Component Options dialog, do you see the field for Pegs? When you type in a number, are you clicking the Apply button at the bottom?


#10

Yeah, I even went through and updated all the functions in the component attributes. Then right clicked on the component and clicked “redraw”. This is what I’m looking at now :frowning:


#11

Try this… open your Ruby Console (from the Windows menu), and see what it says when you change the number of Pegs and click on Apply.

It SHOULD come up with a message that says something like “0.009439 seconds to redraw”


#12

Ok, here’s what I get after hitting apply:


#13

Woah! Since you are seeing this, try turning off any other extensions that you have installed, and try again (go into Extensions in the Preferences window and un check all extensions) - you may have to restart SketchUp, depending on the extensions. Give it a try then with Ruby Console open and see what happens.


#14

I unchecked all of them and restarted but got the same messages in the ruby console. I did notice, though, that not all of the extensions I have under “Extensions” and “Tools” were in the check box list. For example I have “Make Faces 1.4” under “Tools”, but it doesn’t appear in the preferences for me to uncheck.


#15

Hmmm… it MAY be an issue with Dynamic Components… try heading over to the SketchUp Extension Warehouse and downloading the Dynamic Components extension again. See if it is working, then.


#16

Just as an aside, dynamic components could use an array function/behaviour - the copies function is rather cumbersome, even for a simple rectangular array.

Anssi


#17

Reinstalling dynamic components worked! Thanks for the help. This little project I’m working on is going to blow my boss’s mind, so I really appreciate it! :smiley:


#18

WOO HOO! Glad to hear that it all got worked out!