Dynamic component not showing copies


#1

Hi there, I’m fairly new to Sketchup and I’m building a dynamic component. However, the copies are not showing in the component. I can see that there are a certain number of copies, but ca only see one (maybe something I’ve done wrong). Any help is much appreciated.
Thanks


#2

Could you upload the dynamic component?


#3

In what context? By using “Copies” you are creating multiple instances of a single component, with the “copied” instances not editable individually. If you use the Outliner, you should see one instance for each “Copy”.

If you are editing the geometry, what is the setting of View -> Component Edit -> Hide Similar Components? If it is checked, then SU hides the copies when you edit the original.

It would help if you would include a bit more context detail, and perhaps the component itself (use the upload button, # 7 from the left in the forum post window).


#4

Here you go, thanks for the helpQuestion.skp (223.9 KB)


#5

The file you posted has no Copies function defined.

Note that unless you specify the x, y and z for each copy, the copies will be placed exactly on top of each other. Usually it is done by specifying a distance multiplied by the ID of the copy (copy * yourlength) with a more complicated formula if you need rows and columns.

Anssi


#6

In other words, your original “Racking upright” and it’s 3 copies are occupying the same space. They are all there, but you can’t see them as distinct from one another.


#7

OK, thanks for the help…I said I was new to it :slightly_smiling: