Various nonsense dynamic component errors with Sketchup 2016


I am struggling with this more than a week now. I tried to eliminate all possibilities, tried on different computers, in clean models with different approaches. But now it is seems like the issue originates somewhere deeper. Could you please help. So I made this simple example to illustrate the problems: a simple fence with pole, picket and a concrete block.

First issue is that the COPY number 1 is just simply missing. There is the original componenet and the number 2.
[See the first 2 images]

And there are issues like this when component appears randomly where it should not. When I go to formula view of that specific element it gives a nonsense error like this:
[See the last two images]

Also time to time I get circular reference error when there is clearly that is not the case or the ERROR: Callback function error: Unspecified error @ / dcbridge.js[601] [1382]

Can you share the SKP? Without looking at the actual file, all we can do is guess.

Of course. Thank you.F.skp (458.2 KB)

Weird… not knowing how it was created, I can’t figure out what that “extra” post is doing. However, if you select it and delete it, the DC seems to work just fine…

Hi @ZHarchitects

COPY is not an attribute that should be explicitly set. The COPY attribute is available to use in other formulas, but can not contain a formula as you have it set now. Delete the formula from the COPY attribute from “P copy 001” and the DC should work.

Thank you guys. @TheOnlyAaron That workaround works in this case. For long that extra bit did not appear. It appears only at certain sizes. Unfortunately have many similar issues when there is no element to delete. The source of the issue should be eliminated somehow.

@jim_foltz What you say is interesting but I dont fully understand. Could you please explain. By default I dont have #1 copy but when I use Aarons workout I dont have the mentioned “P copy 001”. And the COPY attribute is read only so there is no formula there. What am I missing:

The Copy attribute is an ordinal number that distinguishes between individual instances created with the “Copies” attribute, starting at 0 for the original item.


Thank you Anssi. That is absolutely clear for me, that is the basic principle behind the dynamic component and that is how I used in this example.
Just trying to identify the source of this misbehaviour (missing and obsolete invalid copies). Jim Foltz has proposed an idea: Not to use formula in the COPY attribute. And what I am saying I haven`t used formula (see the the screenshot), and anyway would not be feasible to do such thing as the COPY is a read only attribute.
So the question is still open. What causes this miss behaviour?

I am saying yes there was a formula set for the COPY attribute for the component P copy 001

Yes, but the point is that it was NOT set by me. It was/is generated by Sketchup. Otherwise I could fix it. And only that one particular instance has this nonsense formula in the COPY attribute. Not the 0 not the 2 or any other just the number 1. Why?
Of course the workaround works if I select this misbehaving item and delete it or fix the copy attribute. But there is an issue with that: This copy not always appears in the model. Often the only thing we can see is a missing instance. And when it stays hidden we can`t select it to do the fix.