Multiple Dynamic Components Attribute Bug

bug

#1

Hi there,

I’m having an issue with a dynamic component that I’ve made. It works absolutely fine… until a copy is made and an attribute is changed.

For some of the groups the new attribute is adopted. For most though, even though the attribute has changed and, hence, all of the attributes that reference said attribute have changed, the dynamic component computes the formulae using the attribute of the original.

I’ve gone through all of the formulae, they all seem to be referencing the correct thing. It feels like a bug and I would really like to not have to remodel it (especially as the same problem could still occur).

Any thoughts?

Rob

18-07-30_FJS_STBOX.skp (990.2 KB)


#2

Try using “Parent!” instead of “DC!” in your formulae. Also I notice that all of the subcomponents are Groups and not components. This may be part of the issue, not sure.


#3

Thanks for your quick input.

I just tried a few groups changing the “DC!” to “Parent!”, but no luck. It brings the attribute into each group correctly (using “DC!FJS_03_Height”), the problem seems to be when this attribute is put into formulae in the groups within that group.

BUT, then I tried turning the groups into components and it looks like it’s done the trick… why is that?

Thanks again!


#4

With Dynamic Components, everything should be in a component. Don’t use groups. Always components.