Dxf export for woodwop

i am having trouble to export a simple flat contour to a working woodwop file.
when I export as 2D from SU2020 the result is that I get nothing in woodwop, however I do see the complete drawing in the Woodwop DXF-import tool but only in one layer, were the original Sketchup drawing was made in several layers. when I export in 3D from SU2020, I don’t see a lot in the Woodwop DXF-import tool but when it opens in woodwop I do see my working area in the same size as the original sketchup drawing. basically I am missing the poly lines that need to be cut. al layers are named as they should… need some help here.

I’m not familiar with Woodwop but if you share the .skp file and your .dxf file, maybe we can help.

desk 1_2 2D.dxf (127.0 KB) [desk 1_2 3D.dxf|attachment](uploadesk 1_2.skp (96.1 KB) d://nRSBKQLkj38r3gGtgkesSpdBN9r.dxf) (759.5 KB)

Well, the .dxf seems to show what I would expect when I open it in a CAD program.

Seems like it matches what I see in SU pretty well. I would have used Zoom Extents before exporting but that may not matter.

I’m thinking you need to talk to the Woodwop people about why there is nothing displayed when you open the .dxf file in there application.

And what seems to be wrong?



I don’t see anything wrong with the .dxf file. It displays what it seems it should. So if that’s not showing up in Woodwop, you need to look there for the problem.

As for the SketchUp model, I see things that I would do differently but I don’t think any of those things would have any real affect on your .dxf file.

I can see the dxf in the dxf-import tool from woodwop but i dont see the layers so when i import this dxf into woodwop i see nothing wich i perfectly understand

The SketchUp 2D DWG/DXF exporter doesn’t respect layers. It exports a 2D vector image of what is visible on your screen. Everything exported becomes straight line segments. The exporter can when desired export section cut edges and profiles to separate layers, everything else will go to layer 0.

The 3D exporter respects layers and arcs/circles.

1 Like

I missed out that you were using a 2D export instead of 3D. Do what Anssi suggestes and try that.

Ok, i’ll check the woodwop support.

Thank you for the quick respons.



Anyway it did work with my older version of sketchup. That’s weird not?

Did you see Anssi’s post? Did you try what he suggested?

When i export as 3D i get the working area in the exact dimension as the original SU drawing but i dont see the other layers.

Out of curiosity, try this one faces removed IanT.dxf (373.5 KB) (think version might be too late for you)

Or maybe this one: faces removed 2 IanT.dxf (414.2 KB)

Yes i read his post, and tried it but i only get the first layer wich bassicly is the work field contour

It doesn’t work, thanks for the effort.

I only get the first layer displayed on my woodwop system

Maybe a weird question, but could it have something to do with the fact that I use sketchup and the dxf export on my MacBook and the dxf import to woodwop on a pc desktop?

A good catch, @IanT !
I tried several options with the 3D exporter, and checked the results with Rhino (don’t have AutoCad at home) and I found that when the model has faces, the curves that form their edges don’t export. When faces are erased, the curves export.
@Dave0606, The interior curves certainly are there in the file that IanT posted. If you don’t see them, I would guess that the layer is turned off in Woodwop, or something else is at fault with that.
I tried with a simple model: I drew two circles, a smaller one inside the larger, and my export looked quite OK even when the faces were not exported. There was a glitch, though, the inner circle was doubled…

With the export faces checked the resulting DXF is a mess of lines.
With the export faces unchecked the curves fail to export completely. The remedy were to simply remove the faces to get something in a DXF viewer that looks presentable.