Dwg to skp - distorted faces

Hello there!
I’m having a problem when importing 3d files in sketchup. All the faces and lines look distorted, and only if I explode everything twice will look normal, but then it gets too difficult to edit walls, furniture, etc.
On the picture below you can see how everything looks in the skp file.
How can I import all the 3d stuff that I designed in autocad, without them being distorted like that?
Thank you in advance.

I’m quite curious about the need of using this plugin, as I find more and more solutions given by this forum users. Is that something new about how Sketchup imports dwg files ? (I recently upgraded from 2018)

@irene.g , can you attach the dwg file you imported to get such a result so I can have a look ?

I’m using sketchup pro 2018 - Version 18.0.16976, and until 2 days ago I could import the files whithout this happening.
Here is the dwg.

test.dwg (1.2 MB)

I see… that’s because your model I very far away from the origin, in autocad. start the move command grabing some part of your object as a reference point in autocad and type 0,0,0 to move it at the origin. Save and import in sketchup.

By the way, for a couple of versions now, sketchup warns you when you import dwg files that have this problem :
“Some imported geometry is extremely far from the
model origin. If you experience any instability with
your SketchUp model, please delete that geometry
from your .dwg/.dxf file and import again.”

So you know when something is wrong

In Outliner select everything and then use the Eneroth Line Up Axes extension

I’m trying to use this plug-in but I can’t find it, even though I installed it.
I’m using a mac, does that make a difference?

no need to use the plugin (no offense mihai !), if you follow my steps it’ll work alright ! always make sure you’re not miles away from the origin in autocad

I moved the objects on 0,0,0 and I still have the same problem!
Sketchup doesn’t show any error messages when I import the file :confused:

The dwg file was imported to 0,0,0, but the groups inside it have their origin points far away. Paul, you should move each axis for each group to Origin of the model. The plugin does this for you automatically.

Consider the option in which you cannot edit dwg in Autocad.

Irene, see in Extensions

2 Likes

that is weird… here’s the dwg file once I moved the model back to the origin, and it imports just fine : test corrected.dwg (1.1 MB)

yes, it worked!

thank you so much for your help!!

1 Like

well… it seems it’s high time for me to get a hand on this plugin then ! :grimacing:

1 Like

I wonder if this DWG too was exported from Revit. I wouldn’t know how to create this in AutoCad - the objects report totally crazy bounding box coordinates. In Revit you get this when you export using “shared” coordinates.

Besides Eneroth’s extension, exploding and re-grouping also fixes this.