Dwg problem

still the same person. i cant understand why the dwg is the problem yall, cause i can import jpeg and skp files, i also can export the file into PDF but cant seem to export/import any DWG file. evertime i try to import the DWG it says like

and everytime i try to export the file to DWG it says
Screenshot 2024-01-13 002745

i dont think the file is the problem yall it stress me out :sob:

Can you share the file to check if I can import it?

2024131.skp (201.5 KB)

do you want to export as 3D or 2D?
I was able to export as 3D dwg without any issue.
2024131.dwg (102.8 KB)
I opened on Draftsight.

on 2D models! i able to export it to 3D but cannot do it on 2D, its weird

Exports 2D fine for me:
2024131.dwg (277.8 KB)

What do you have set in the options window under 2D .dwg export?

Here´s 2D dwg.
2024131.dwg (11.9 KB)

i dont know, i thinks its the sketchup malfunction, the setting option was fine before

Have you tried repairing your SketchUp installation? Right-click on you SketchUp installer, select Run as administrator from the context menu, and click on Repair when the button appears.

Just in case the repairing or reinstalling sketchup doesn’t solve the problem, you can just delete the 3D geometry in Autocad or the cad program you use or in sketchup cut to the clipboard(Ctrl+X) the 3D onject, then export as 3D dwg after that paste the object if you don’t want to lose it, you’ll have either way just the 2D floor plan. If you need to add more things to the model, like furniture, you can use the plugin make 2D from Curic and repeat the process.