Pro 2022 not exporting DWG

Anyone have a fix for exporting to DWG? Sketchup isn’t creating the file when I export. I’ve made sure the options boxes are checked for profiles and sections cut and I am asking it to export to 2018. thx!

1 Like

2D or 3D? Can you share the .skp file so we can see what you are working with? I just tried exporting .dwg files from the model I have open in SU2022 and that worked fine for me.

HI Dave- 2D/ plan view. Trying to export a section cut showing the plan in parallel projection. I’ve done it this way in previous versions of SUP, so maybe there’s a new thing I need to do in 2022? I’ll attach the file. Thanks!

int - 3.skp (8.1 MB)

Hmmmm… It worked for me in SU2022. I just opened your file, check to see that the Camera was indeed set to Parallel Projection and then exported it. Does this open for you?
int - 3.dwg (158.8 KB)

When you installed SketchUp did you right click on the downloaded installer and choose Run as administrator?

Thanks for checking! Yes, I did install as admin.
So, I just restarted my computer and tried again. This time, my avast virus protection just popped up, saying it was blocking sketchup from completing the task, which it didn’t tell me before. Wouldn’t have thought of that one!

I wouldn’t have thought of that either. Did you tell Avast to “Avast! Stop blocking SketchUp, you scurvy dog!” :slight_smile:

1 Like

Were you trying to write the file to some odd location, like directly to the cloud, or to a folder that is synced to the cloud (like Dropbox or Google Drive or…)?

We have had the same issue in 2022. 2D and 3D Exports create DWG files that cause a file error when opened in AutoCAD.

We have tried 4 different versions of AutoCAD and 4 different machines. AutoCAD online will not even open the files.

We are on Mac BTW.

I don’t think it is a file permissions/security issue as seems to be the lead you are pursuing.

That is not the same but a different issue.
What is in the error? Are you exporting to a newer format than what AutoCad for Mac can read?
Can you post examples?

The error is that the file cannot be opened or comes up empty in autoCAD.

No, we have tried all export version options. That is not it.

2022_03_13-cad-PLAN.dwg (2.0 MB)
example file attached.

Anyone made any headway on this issue? Apparently not everyone is having it. It is extremely frustrating that something so fundamental was broken in the new 2022 release.

I’ve had the same issues! The only way I’ve managed to do it is by using the free website version to export it to the DWG file which takes a lot longer but better than nothing. It’s frustrating that the version I’ve paid for won’t work but this is the only way around the issue I’ve found.

Hi, I’m having the same issue… im in a MacBook Pro, and I export to DWG and when I open the file I can see one or two lines but not the complete drawing… have you fixed yet?

Can you post an example DWG? Lines might have the same colour as your CAD background.

hv1.dwg (280.8 KB)

According to DWG TrueView 2022 the file is damaged. What should be in it? How large is your model? Are you using the latest maintenance version of SketchUp 2022? Can you try it in 2021? Are you exporting to “the cloud” or a cloud-synced folder? Does it work if you export from LayOut, or use the 3D export option?