DWG import to LO

mac

#1

I have imported a DWG into LO. Both drawings are attached.

The original is all in metric but the dimensions showing in LO are in imperial. The LO template setting is metric.

I don’t want this to happen so is there a way to make sure that a metric dimensioned DWG imported into a metric LO template ends up with metric dimensions and does not get “Americanised” in the process?

Imported DWG.layout (87.3 KB)
DOCKING LODGE - WINDOW BAY AT CORNICE LEVEL.dwg (176.4 KB)


#2

Hi simoncbevans, the best way I have found to import metric files is by doing this.

  1. In Acad, I set the PaperSpace viewport to a scale… in your case I set it to 1/20xp and adjusted the viewport to show all the geometry. Save the file.
  2. Open LayOut and select a template, I selected A3 Landscape.
  3. File -> Insert… (select your dwg) then Open
  4. Select the Pape Space option, Select Ok
  5. The dwg will be imported as Scaled Drawing 1:20
  6. Single Select the scaled drawing.
  7. From the Dimension Style inspector change from Decimal Inches to Decimal MM, then
  8. Change the scale to 1:20mm

Pattern or Hatch scale will be off as well so set the Scale from the Pattern Fill inspector. (Adjust to your liking, but I set it to .75x scale.

It looks as though one of the leaders came in kind of strange but you can drill down into the Scaled Drawing to adjust.

Let me know if you have any problems.


#3

Fantastic! I will try that.


#4

Also… LayOut groups entities based on the ACAD layers so you can adjust stroke by double clicking to enter the Scaled Drawing and set the Stroke to the group level.