DWG Import Creating High Number of Components

2017
dwg
import
bug
components

#1

When importing an AutoCAD DWG, SketchUP is creating an overwhelming number (>1000) of components. It’s making it impossible to open the components tray/browser without crashing the program.

After a long wait… SketchUp did display the component list within the model. The preview shows all these random lines, but when trying to actually place the item in the model nothing appears.

Running a model purge does not eliminate the issue. Just started using Pro 2017… I’ve never experienced this problem before with previous versions of SKP.


#2

Have you tried importing this same dwg in previous versions of SU? Trimble didn’t announce any changes to the dwg importer for 2017, so unless the file just happens to collide with some internal change the problem is likely with contents of the dwg itself.


#3

Just tried with Skp8 and it imported just fine. The DWG itself is only 2 or 3 lines… nothing complex.

In 2017 it appears to be importing unused blocks/fonts/symbols (items not actually in model space, but as part of the template)… just by judging from the component preview window shown in my last post.


#4

If you upload the dwg here, one of the AutoCAD experts may be able to tell you more about what is happening.


#5

They could be AEC entities - I get this from time to time with Surveyors.


#6

new block.dwg (2.1 MB)

Here’s the DWG file (it’s happening to any DWG I try to import).


#7

You ought to Purge the DWG in AutoCAD before importing it - it’s full of dross - hundreds of unused blocks etc.

Otherwise after the import, you could Purge the model - but it’ll take forever !

I suspect you have a batch of CAD files full of dross…
Although I agree that the SketchUp purge unused is performing very slowly in this case !
BUT using my own Purge All tool works quickly !

http://sketchucation.com/pluginstore?pln=PurgeAll


#8

Thanks TIG! That seems to be the option I have to go with. I didn’t have this issue before with SketchUP 8… so it’s just a new step I’ll have to add to the workflow :frowning:

Appreciate everyone’s efforts.