Drawing very small objects

Hi,
I am a beginner - please assume I know very little.

I wanted to try to draw an LED (light emitting diode) as a practice exercise.

I was hoping to use the ‘follow me’ route.

I started to draw the profile of the head of the object but when I went to add a curve for the head of the LED, I got a message saying the number of segments in the semicircle is too large. I have changed that number to be very small - e.g.4, 1 even point numbers.

Perhaps I am asking too much or perhaps I should use a different tool - I am a beginner.

Have you any ideas?

Thanks
Ciaran

SketchUp works best at a bigger scale than that. You can still draw your LED, but draw it much bigger. Try drawing in m instead of mm. The more segments in your arcs, the smaller each edge is. At 1000x scale, you should be able to use the number of segments you want. Vertices closer than about 1/1000 inch get merged together in SketchUp.

When you’re finished, you can scale it down 1000 times and the tiny faces will still exist.

As McGordon suggests, modeling at 1000x normal size is a good way to go for something like that. The easiest way to do it is set units to meters and model as if millimeters were meters. If you were modeling the LED outlined below, you would draw it so the envelope is 8.6 meters tall.

And if you are only doing this for practice, you can skip scaling down when you get the model completed.

Hi,
Thank you for the reply, I will give this a go.

Can I ask a slightly different question, is there a way to make the screen go back to the ‘home position’ after having scrolled away to do something else?

Thanks again.

Ciaran

Hi, Thanks for the reply.

Yes, I see what you mean. I will give it a go but I think scaling may be a useful thing to learn too, so I’ll probably try that too.

Thanks again.

Ciaran

There’s Camera Menu -> Zoom Extents, which fills the view with your entire model. This is one you’ll use a lot, so it’s worth setting a keyboard shortcut for this or learn the default shortcut. Another useful one is Zoom Selection, available when right-clicking on an object. Zoom Selection fills the view with your selected objects. This can help you find objects that appear in the outliner but you can’t find them in the model view. If you want to change the shortcut for context menu items you need to select something before opening the shortcuts preferences.

Learning how to scale up and down can be useful. You might also find it useful to learn what has come to be called The Dave Method.

There isn’t a normally specific ‘home position’ but you can create one by using a scene. Set it up before you start modeling or create a new template that contains a “home” scene.

Hi,
Thank you again for your reply.
I think, if I don’t delete the person shown at the beginning, the ‘zoom extents’ seems to bring me back to the start point - would that be like setting up a scene?

Thanks

Ciaran

Not really, scenes are a specific function in SketchUp. If you create a scene with View -> Animation -> Add Scene, it adds a tab to near the top of the window. If you orbit around the view then click the scene tab, the view will snap back(or animate slowly back) to what it was when you added the scene.

Scenes can control lots of settings: camera location, hidden geometry, hidden object, tags(layers), section planes, style and fog, shadows, axes location.

If you find yourself losing your objects you could set a ‘home’ scene that gives a nice view of your drawing so when you get lost you just click it and it sets the camera the way you want it.

Hi, I am having trouble scaling the drawing down. I have managed to make an LED and a mount (using all the sizes as m). I have joined the two groups together and now want to scale them.
When I select the drawing and suggest a scale factor of .0001 - I am told it is an invalid scale.

Perhaps there is a chapter in one of the courses that would explain this to me?

Thanks

Ciaran

.001 will scale 1m to 1mm

If you really need it to 1/10,000 you could scale it down twice. Scale 0.001 then 0.1
I don’t know why it has that limit.

https://help.sketchup.com/en/sketchup/scaling-your-model-or-parts-your-model

hi, I did scale it in stages and got it to size.

Thanks for the link, I will read this just now.

Thanks

Ciaran