Draping not creating closed surface on terrain


I’ve encountered this problem a couple of times. I have a terrain surface that I want to drape a flat surface on. Once draped, the new lines could be off by a millimeter, which makes the draped surface not closed. I want to color this new surface with a different color than the surrounding terrain, which doesn’t work because SketchUp thinks it’s the same surface… What am I doing wrong?

how big is your model ?
if it’s really tiny, you may encounter this kind of problems

The terrain is a group. Your drape operation has probably placed the created edges outside the group. You might try to copy the draped edges, open your terrain group, and paste in place.

draping on a group should work. Besides, the created edges would be grey

Attaching the model would help us help you.

Here’s the file!
Test drapering.skp (3.3 MB)


The first gap that @mihai.s identifies is sub-millimeter.
Screenshot - 12_14_2021 , 6_45_19 AM

The one at the other end is about half as big.
Screenshot - 12_14_2021 , 6_47_24 AM

You could shift the shape over a little bit or use the Dave Method. Select the two groups and create a component. Then copy it, scale up the copy and do the draping. Exit out of edit mode and delete the giant copy and return to the original.

Yes, but is there no way of preventing this from happening?

Dave Method.

This avoids needing to scale back down.

If you move the shape over a tiny bit you can get its edge aligned with the edges of the triangles, too.

there are workarounds, like :

  • push pulling your shape so it goes through your surface you wanted to drape it on, and while in the same context, intersect.
  • using stamp instead of drape with a 0 offset, select the outline and create the surface with curviloft
  • scaling your model a 100x up do the operation and scale it back down
1 Like

Is draping the only way you want to get that geometry on the terrain?

Maybe you want to try intersecting faces (with model) instead, like the .gif below?


This is the solution I need. Thank you. I am having this same issue with a switchback path up a hill. The path worked in the first version, but the new version is not creating a closed path on the terrain - likely due to the minuscule gaps that you mention. I do not understand the scaling operation, but I do understand extruding and creating an intersection. Personally, I consider this a flaw in SketchUp. As long as I create a proper closed path, I would assume that it can be draped on a terrain.

Actually that did not work for me because I already have a complicated model with buildings and other features intersecting the terrain. So now SketchUp is frozen and I have to force quit. I will have to try the other methods.

So I solved my problem. I turned on hidden geometry and double clicked into the terrain so I could add material to individual triangles of the path. I used the Select tool and the Shift key so I selected a bunch of triangles at once and worked my way around the path until I came to a triangle that was unbound by the path edges. I drew a line to close the one tiny break, exited out of the actual terrain, turned off hidden geometry, and was able to select and apply a material to finish the whole path. Yay.

1 Like