Drape tool lines are not correct

face
sandbox
drape

#1

Update: I used the stamp tool to create a new surface for the road instead. Then I used the drape tool again for the inner lines of the road, and not even those create a new surface even though the terrain from the stamptool is completly flat.

I’m draping lines but as you can see the road is not its own surface (as it was before draping it on to the terrain). Any suggestions what the problem might be? I’ve tried correcting some of the surfaces by adding lines but it only works on occasion (because of the terrain I suppose)
The model is about 50000mm x 50000 in size.


#2

There’s probably a gap due to the edge crossing a tiny part of a triangle. Examine the edges of the road closely to find it. If I had the file I would give Eneroth’s Weld tool a run over the geometry. After it has run I would select the welded edges and see where they stop. Those would be places to look for gaps. If it really is due to some tiny triangle being formed, you could use the Dave Method to get around that or edit the terrain a little to eliminate the small triangle.


#3

Thanks for the suggestions! I can’t find any gaps, tried the Eneroth´s Weld tool but nothing happens… more ideas?


#4

Try draping just the road portion a second time (and parcels that didnt form)

Charlie


#5

Did that, but the lines ended up slightly on the side, not a single one on point…


#6

Can you share the SKP file?


#7

Sorry for the delay, had to wait for approval! It was too big to upload, but you can download it from here: https://we.tl/Aw8kPDG6E2


#8

ThomThom’s edge tools can find gaps, that might help? It can fix them too under certain parameters. But at least will locate them.


#9

1) Overly complex terrain mesh.
Use the Simplify Contours Tool to reduce over-segmented contours before creating the TIN.
https://extensions.sketchup.com/en/content/simplify-contours-tool


2) Sloppy modeling.
The site plan geometry is a mass of gaps, overruns and retraced lines that missed.



3) Improper use of SketchUp’s layer system.
Raw geometry always lives on the Default Layer0.



#10

Thank you for the detailed reply. 1, Didn’t know that, thank you! 2 and 3, The “sloppy modeling” is due to being imported from CAD, I clearly need to edit lines and check the layers next time before draping.


#11

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.