Downloading Plugins

Hi All,

I’m trying to download Bolt Maker vX11 by Sam D Mitch. Each time I hit the down load button, message reads : File does not have the Apps associated with it for performing this action. I have no idea what to do next. Please advise.

Regards,
TropicalGuyCns.l

Bolt_Maker_vXII.rbz (5.7 KB)

Worked fine for me. Did you get it from here? https://sketchucation.com/pluginstore?pln=Bolt_Maker

Hi Eric,

Thanks for the prompt reply.
Even when I clicked on your reply, I got the same message.The problem for me is that I don’t know how to find the Apps needed to download this plugin.

Sorry I’m still learning all that’s needed to function with SU.

Regards,

TropicalGuyCns.

I’ve never heard that before. Have you tried using a different browser? And do you have a SketchUcation account? As you need to be logged in in order to download extensions. Also, notice I posted the extension itself. Have you tried installing that?

This is most likely a Windows problem.
How much room is left on your harddrive?
Can you download anything else?

Eric,

Yes I have an account and I’m logged on. When I click on to the extension in your post, I receive the same message.

Mike, I have plenty of space on my HD.
Attached is the message.

Regards,
TropicalGuyCns.

Right click on it and choose Save Link as…

Hi Box,

I tried that , got the same message.

Regards,
TropicalGuyCns.

This screenshot seems to be showing that you are trying to open an already downloaded .rbz. Don’t do that.
Go to the Extension manager in SU and use the install extension button, navigate to the download folder and select the .rbz there and SU will install it.

Box,
The Plugin is showing in Extension Manager, it has a red tick to the left of the title, still wont open, what next

TGC.

Box,

Also says Unsigned under the Title.

TGC.

Can we see a screenshot of this.

By The Way, have you tried restarting sketchup?

Many older Plugins/Extensions RBZs are simply not ‘signed’ [too much effort for no reward!], but provided you get the RBZ from a reputable source its legitimacy is not in question.
SketchUp’s Extension Manager has an option to change its ‘Loading Policy’.
If it’s set to ‘Unrestricted’ then unsigned extensions/plugins will load as SketchUp starts.
However, you will need to restart SketchUp to fully engage this setting…

Here’s a tutorial for the tool: https://drive.google.com/file/d/0Bw8zdmaKDWIfZDdkNWM5OGEtMDZiMC00NTYxLTkyODMtY2NkY2ZmYmI1OGJl/view

Also note that individual tools can appear under different menu lists and even context-menus, and even toolbars…
What have you tried to run this tool ?
BoltMaker is activated from Extensions > Bolt Maker XII
That menu item is called ‘Plugins’ in older SketchUp versions…

If you still have issues running this tool, then try opening the Ruby Console beforehand and report any error messages…

1 Like

Hi All,

Finally I have this plugin installed, thanks for all the help. I have uploaded an example to see how it all works, I keep getting some confusing messages.

Would appreciate some more assistance.
Regards,
TropicalGuyCns

Unit 1.skp (23.2 KB)

Please describe in detail what you do when you try to use the plugin and provide images of the confusing messages. It may be just be a matter of figuring out how the extension works. It worked when I tried it:

Thanks to all for your knowledge and assistance. It’s working now, just took a lot of perseverance.
Just a side note if I may, I have had SU for a couple of years now and have not used it to its potential. The learning curve for someone that is not very skilled with computers is quite steep. I used this Forum in the early days of installing SU, but I must say that some of the responses were quite intimidating. Again thanks for time and effort.

Regards,
TropicalGuyCns.

This sounds like it’s related to a problem I am having. I get a message when I open Sketchup Pro that “there are two extensions ready to be updated”. When I go to the Extension Manager, Manage, Install Extension I get a window to a folder on my hard drive that only provides me with an option to ‘cancel’. The ‘open’ box is greyed out. There are two of four extensions noted in the Extension Manager, Manage window where the ‘update’ button is red rather than grey. I then get a message “You must be signed in to be able to update extensions”. I press the ok button and the message disappears but nothing else happens. What am I supposed to be signed in to? How do I do that? Where do I go to do that? Thanks in advance for any help available. Nick

Go to the bottom left of the sketchup window and you’ll find an Icon of a little man. Use that to sign out, close sketchup, open again and use it again to sign in.

Actually, I just went back and noticed the ‘sign in’ box on the top left. RIGHT IN FRONT OF ME! I must be blind. Sorry to bother you, got the extensions installed.