Downloading furniture

Hi there. I’m just wondering why I cannot download anything today from the 3D warehouse. I restarted my computer twice and it still not letting me download for example a dining table from the 3D warehouse today. Any thoughts? Thanks

What happens when you try to download the table? Which table? Is this on PC or Mac?

PC MSI. It does nothing. There is a little tiny thing that seems to popped out but nothing is downloading at all.

Again, which table? Share your SketchUp file so we can see what you are working with.

I cannot share at this time. I’m not in my computer. I can later. I’m just wondering if there is any technical issues. I tried to download at least three 3 different tables

I’m not having any difficulty with downloading components from the 3D Warehouse. I just downloaded three dining tables with no problem.

Seeing your model would help us help you.

I see a number of dining table components that are geo-located. Maybe you got one of those? That’s not a problem if your model is not geo-located but it could be a huge problem if it is. Seems kind of stupid to geo-locate entourage components like furniture. Maybe there’s a scale issue or the component’s insertion point is a long way from the geometry.

Ok good to know that. I will try again later. Thanks