3D Warehouse - Need Help


So, I am having a problem with loading models from the 3D Warehouse. It just sits there clocking after I click load into model. I’ve tried deleting the app and reloading. I have tried opening a new document and it all works the same. How do I fix this problem?? I need help because my senior project is due soon.

Have you tried downloading the model and opening it?

Also, can you post a link to the file you are trying to download?

I literally just try downloading any furniture piece and it just freezes my screen. I’ve been downloading furniture for months now into my projects, and it just randomly stopped working.

How big is your SketchUp model file? Have you purged unused from it recently.

I thought that was the problem, but I tried loading a component on a new file as well and it did the same thing.

Do you see the dialog that asks if you want to download it into the current model?

Yes, and I select “yes”. That is when it freezes.

Ok, thought it might be an off screen issue, but obviously not.

Frankly, I almost never use 3D Warehouse that way. I mostly us an ordinary web browser to search for what I want, download it locally to the hard disk, and open it as a new file first before putting it in any of my files. They often need editing or fixing first. Try this as an alternative pathway.

Thank you so much! I will try that.