Downloading files in Sketchup Shop

I have tried to download two files created in Sketchup Shop. When I did so, it asked what version I wanted to download them to. I selected Sketchup 2017 because that is the version I have installed on another computer. I saved them in this format, but when I tried to open them in SU 2017, I go a message that they were created in SU 2020 and that they could not be opened in SU 2017. Not sure what the purpose of saving the files in 2017 format was in the first place, if they cannot be recognized by SU 2017. How would I go about doing this. I want to try something in a desktop version of SU, not its web version.

I just downloaded a file to test this. It’s one I made in Shop yesterday. I selected 2017 and download it. Seems to be working for me.
Screenshot - 1_8_2021 , 10_36_04 AM
When I open it in 2021 I get the message shown below.

Is it possible you don’t have the radio button set for 2017?

I did select the radio button for 2017. I am finding weird things happening with Sketchup Shop. I have been continuing my sprocket creation, but for some reason, when I try to subtract my ring of ball chain from the sprocket, Sketchup Shop will either stop, take a very long to do it (after several messages saying it is not responding, taking up to 10 minutes to execute the subtract function), and then will only do a portion of the subtract. I end up with a ball not subtracted (the ball is sticking out of the sprocket), a ball cavity completely missing (sometimes two), or combination thereof. I was going to try the subtract feature in SU 2017 to see if I had the same problem, but SU Shop doesn’t want to create the 2017 version. Makes me wonder if any web version of a SU file will not work with any desktop version - seems odd, but I am having no luck.


If you have a lot of geometry for the Subtract tool to parse through, it can take a little while. When I created the threaded holes in the cast iron wheel in my example above it took a bit of time and the browser thought SketchUp wasn’t responding but it was just busy. I’ve had similar response in the desktop version.

In your case maybe you need to separate the balls and subtract one at a time.

Are you working at the larger scale like I’ve advised you in the past or are you still trying to model it at actual size?

Do you have 2017 Pro?

Well, clearly that’s not the case. My screen shots show that it works. Maybe try closing SketchUp Shop and reopening it and try the download again.

I do not have 2017 Pro.
I created each of the models (sprocket and balls) by scaling up and then scaling down. I did not try the subtract tool using scaled up models. However, I Just tried the scaling up method and applying the subtract tool and it “worked” in Sketch up Shop. I say “worked” because I clicked on "“Hidden Objects” under the info tab and discovered a number of hidden objects I used to create the ring of balls. As I started to delete them, I had small sections of the “subtracted” sprocket lose their surfaces. After several “undos” and “redos” the surfaces in the sprocket came back and I have removed all the hidden objects in the file (I assume these are bad things to have in a file if one tries to convert the file to “STL” format). No idea what I did to get Sketchup Shop to react like that, but now I have a solid model.
As an aside, during the subtraction process, I did not get any of the “page is not responding” messages either - it went quite quickly. I thought once each of the models was upscaled and reduced, nothing more had to be done to use other tools, but obviously I was wrong or not paying attention. Anyway, will get around to the SU 2017 file conversion over the weekend to see if I can get it to work there.
Thanks for the help. Much appreciated.

Then you won’t have access to Subtract which is part of the Solid Tools. You could buy Bool Tools 2 and use the Difference tool.

It would be better if you just work on a scaled up version of the model. Don’t scale up and down.

Probably erasures due to the small size. Don’t make your work harder than it needs to be. Work on a scaled up version throughout. Set the Units to meters and treat inches or millimeters as meters. In the cast iron wheel above the screw threads are 1/4-20. Since I was creating internal threads, the major diameter is modeled slightly over 0.25 meters.

Aghh! Spoke too soon. When I save the file, I lose the surfaces of small sections within the subtracted sprocket. “Undoing” the save command restores the surfaces, but once I save again, I lose these small surfaces. Tried to save the file under a new file name and got the same thing. Anyway, have to get ready to go, so I won’t be back to this until early next week.
Just saw your other message, Dave. I guess there is no point in trying to use 2017 Sketch Up without the Bool Tools 2.


It’s because of the small size of your model. The end points at the corners of the faces are so close together that they fall inside SketchUp’s tolerances. SketchUp assumes they are the same point and deletes one which results in the loss of the faces.

I keep telling you to work at a larger size and just leave your model that way. (It kind of feels like you keep missing that advice.) If you’re planning to export an .stl file you can probably leave it in the larger size and just set the import size in the slicer. Here’s an example. The wheel is modeled at 6 meters in diameter. I exported the .stl file and imported it into the slicer with the units at inches. ( I won’t be printing this wheel.)

Ok, am slowly getting it. I did not realize the model should be kept at its larger size in its end configuration.
I have no experience with slicer programs, but once this Covid pandemic gets under control, I may have access to a community 3D printer that I will try my model out on. I do not know their software configuration or programs for the printer at this time. Just trying to get a handle on modelling first!!
Thanks for the advice and help.