Download from Warehouse, Program Crashes

It does not matter what I download it crashes every time. The imported object isn’t large.

Before you ask:
-I have purged unused
-It crashes even on a blank file
-File is only 1,750 KB
-All extensions are updated
-I have a new MSI gaming laptop for Arch school

What do I do? Kinda have a final render due tomorrow for school!

What exactly do you mean by ‘It Crashes’?
Does it shut down and give you a bugsplat?
Does it just close?
Does it freeze and say Not responding?

It just closes and does not autosave, no bugsplat or anything! Once downloaded, the extension warehouse window closes and then the whole program closes. It does not freeze or “not respond” it just closes and I lose all unsaved data

Can you provide a link to the warehouse object?

Someone else could then try it, and see if the problem is with the file, or is something in your setup.

It crashes no matter what I download. I’ve tried 5 different objects and it still closes.

When you installed SketchUp on this computer did you right click on the downloaded installer and choose Run as administrator?

Yes! I’m the only user and the administrator.

For clarification, I did a much larger project a few months ago with this computer and was able to download and use files with no issues?

That’s not the same as right clicking on the installer and selecting Run as administrator.

So if it isn’t the components you tried downloading from the Warehouse, what changed on your computer. SketchUp 2019 didn’t. Maybe it’s a graphics driver update that was pushed with a Windows update. That’s a common problem for many users.

I apologize, I meant yes I did right click and run as administrator when I downloaded the program.

Just rolled back the driver and it still crashes ¯_(ツ)_/¯

Maybe try updating the graphics drivers direct from the manufacturer’s site.

You never did tell us what these components are that you’ve been trying to download from the Warehouse.

Dare I say it, did you try turning it off and back on again?

It pains me deeply that I never thought to try this, but it worked! The stress of arch school and this pandemic have apparently made me stupid.

1 Like

I’m having a good laugh here, not at your expense just at the absurdity of things.
Glad it work.

1 Like

I will point out tho, that I would never do something like this without rebooting.