Double Shadows on Snapshot and Terrain

Hi all,
Well this one really hurt. Our customer wondered why some buildings in their area had 2 shadows - one was dark green and the other dark gray. We had done a quick shadow study for their surroundings, geo-located with Digital Globe base terrain. So it looked fine with Snapshot alone. With Terrain alone, nothing really stood out with a quick view. They reviewed both versions and noticed the extra shadows. Afterwards we converted terrain to a solid color and the 2 shadows were very clearly there on some of the buildings. Reviewed again and noticed that some buildings were not tall enough to generate the “extra” shadow with terrain turned on.
Anything SketchUp can do to fix this? We’ve been doing these since SU16 and are current subscribers with SU21 so we were amazed it didn’t show up long ago !

Probably what’s happening is the terrain goes below the ground plane. If that’s the case, go to the Shadows panel and turn off On Ground at the bottom.
Screenshot - 4_12_2021 , 3_49_50 PM


Thanks DaveR! Here in the greater LA area, to get a clearance for building some new or replacement structures, you have to present Shade/Shadow artwork for all seasons, 3 times a day showing any interference with existing conditions. They have to be accurate as possible even in hilly areas. So thanks for showing me one solution. We’ll try that and hope that satisfies the customer !

It’s not really one solution from Dave, more like the solution. SketchUp projects shadows onto the ground plane which is the X,Y plane that corresponds to Z0 on the global axis. It does this by default so that you can see shadows from objects on the “ground” without having to draw a big rectangle of floor geometry to cast shadows onto. Turning off the ground plane shadows tells it not to do this. Looking at your image it looks like your buildings begin lower than Z0 of the global axis, not sure why. So you could raise all your geometry up in the Z axis, but unchecking the “on ground” the box is quicker.

Is the image you posted from after unchecking the box in the shadow window?

Thanks endless fix ! That image was before unchecking the box. Attached the “after” image with the buildings’ positions adjusted to meet the terrain. Now to grab the roads and “drape” them onto the terrain !