Does this clipping glitch stay with the model on other PC's?


#1

I’m getting this clipping glitch and once it happens, if I save the file, the glitch returns if I re-open sketchup and the file.

My question is, will this also glitch out if I open the file on my other computer that has sketchup pro on it? (I save my files to dropbox and work on the same models on my work computer as well as my home computer).

Luckily, I did create a different file so I can return to an older file. But I want to please know if this graphical glitch is permanent with the model, or just permanent on my single computer?

the video lost some of the time but the models is supposed to be a complete ring but moving the camera and orientation causes parts of the model to disappear.

I would think that it’s the graphics card on this computer allowing clipping and my other computer should not have the same clipping?

via Imgflip GIF Maker


My project file seems corrupt after a sketchup crash
#2

It is switching to the app whose icon is just to the left of the SketchUp icon on your taskbar. Is that the Dropbox icon ?

If so try to copy the SKP to your local drive and work on it from the local drive, then save it manually to Dropbox when done.


#3

OK, thanks. I’ll try that. I think there is some kind of issue by me always saving directly to Dropbox. It sometimes creates a second file that has the same name but is not recognized automatically as a sketchup file. So you are probably on to something there.


#4

Have you tried switching between Parallel Projection and Perspective in the Camera menu? This usually resets and takes care of the clipping plane when i get it…


#5

The clipping plane glitch occurs when there are any entities far away from the origin [even those that are hidden/on-off-layers/guide-points/etc], or components/groups with their internal origin miles from their geometry which might otherwise appear to be near the model’s origin.
It also occurs when imported CAD blocks become components/groups but they have been poorly made in the CAD app - so they are enormous but scaled to be small within the imported model - e.g. a door originally made as ‘1000mm’ wide is mistakenly imported into a CAD file [set up in m] as ‘1000’ ! so then it’s then scaled down to suit the CAD model from 1000m to 1m, it appears as 1m wide BUT it’s definition is 1km wide!], so SketchUp has issue reconciling it…
Working at very tiny sizes [~1/1000"], or very large sizes > 2km can cause issues…
So whosoever gets the errant SKP will keep getting the issue !


#6

ok thank you. I tried to work clean. My model is 18 meters on diameter and didnt get any clipping until the very end when I exploded the 3 different components that make the model. Once I did this and started cleaning up the interior faces is when my clipping occured.


#7

I will try that because no, I was not aware that might work.


#8

Bingo. We have a WINNER.

Clipping went away by switching from parallel back to perspective. This reset the viewing and no more clipping. So does this mean it’s a different glitch from the way I constructed the ring?


#9

I don’t know exactly how you went about modeling your ring, but i see it when I work for too long in Parallel Projection mode. Fortunately, a simple toggle between PP and Perspective fixes it! Glad to hear that helped!


#10

That’s exactly what I was doing. I was using parallel projection mode for a long time and then I got the clipping. But I never realized that was the issue.

You are brilliant!


#11

What happens is that when you zoom in and out and orbit in Parallel Projection mode, the camera location changes just as it does in perspective, but you don’t see it happening. It starts clipping when the camera’s “film” plane gets moved inside your model.

Anssi