Do you want to save changes?

I often need to open a drawing, navigate around it, zoom in and out to see things, and then close it without having changed anything. At least, I don’t think I have changed anything. But SU often thinks I have. I guess it is something to do with changes of view within a scene, even though you may not have instructed an update. If I simply open, do not move about, and close, I get no warning about having changed something.

I don’t know how others feel but I find this confusing. If I don’t think I have changed any geometry or scenes, etc, I would expect the system to happily allow me to close the drawing without warning. If I get a warning I start worrying about whether I have changed something which I either want to keep or not.

There may be a good reason why SU logs a change in viewing as a change that might need to be kept but I can’t see why. If others agree that SU should not register such changes, I might move this to a Feature Request.

This is usually caused by a plugin, often rendering ones.


Ah. Well, if that is so, wouldn’t it be better if it was obvious that a plugin had registered the change rather than making it look as if it was due to native software? That would make it more obvious whether a change has in fact been made or allow you to disable the plugin if you wanted.

When navigating around and inspecting the model, do you ever enter a Group or Component context? That constitutes an undo-able action, and it flags the model as changed. (I agree that Enter/Exit should be undo-able, but I disagree that Enter/Exit should flag the model as changed.)

I’ve also noticed that because SketchUp keeps a two-way operation stack (undo + redo), even if you undo everything you’ve done the model is considered changed because the stack still has those redo’s. The only way to tell for sure is to look at Edit menu and see that Undo is grayed out but redo has an operation.

One might argue that this is as designed, but it strikes me as a bug!

I just tested that, undid back to no undo but with redo and it closed without asking me to save.
I’m pretty sure this is due to observers in extensions.

I did some more experimentation, and it seems like this behavior is somehow entangled with making a component. If I draw a rectangle and then erase it, the model shows as unchanged even though “redo draw rectangle” shows on Edit menu. But if I create a component from the rectangle and then undo twice to get back to a blank model, SketchUp has marked the model as changed! I checked - there are no components in the in-model collection.

If there is an observer to blame, I wonder what extension and what it is doing that makes SketchUp think the model is changed? The observer would have to add something to the model object itself, I think?

I remember going through this some years back, can’t remember what the extension was but I obviously don’t have it now.
No save

I don’t have to to get the behaviour reported.

I remember being taken to task by a “proper” draftsman many years ago because I tended to close a drawing however it was when I last looked at it. He told me that best practice was to leave it the way it was when I opened it. This related to AutoCad and so was specifically for 2D drawing. I thin the default view was probably one that included everything in the drawing.

I have therefore assumed that SU operated on a similar principle and that if I tried closing a drawing in a different format from the way it was when opened, that would constitute a change because the software would have to remember the new view so that it opened to it next time. I can even see some logic to that, although I would prefer a means of disabling it.

I think Maxwell had this issue when I tried some years ago. I disabled it more or less right away.

This happens to me every day if I have Twilight Render active. Even the new document wants to save changes when I close it immediately. You can usually see what it did by checking if there’s an undo right away.