Can't redo in SU

sketchup

#1

Does anyone know why the redo feature would stop working in SU 2018? I can Undo, but not redo what I’ve undone. What to do?


#2

You can only redo if you haven’t commited a new change that branches off the old history.

This could be caused by a misbehaving extension that automatically makes changes to the model (for example one that observes the model and responds to an event). Try to disable any new or suspicious extensions and restart SketchUp (you can disable first one half, then either half of it or the other half, = binary search).


#3

EDIT: @Aerilius is on it.

Redo works for me in 18 Pro. Perhaps your last action was an extension function which sometimes are and sometimes aren’t re-doable depending on the extension?


#4

Do you know if layers organizer can cause this? That is the only new extension I added when I upgraded to 2018 and I never had this problem in 2017.


#5

Yes it can. But an update was supposed to fix it.

Check if you have the latest version. And report a bug (as I did some time ago, which then got fixed) if the latest version doesn’t work in 2018 - it did in 2017 after the fix.


#6

All operations are undoable and redoable. There are two things where extensions come in: an extension can group 1000 edge modification operations into one operation (both undoable and redoable). And an extension can listen for events and automatically make changes to the model. If this is triggered by an undo, the undone operation is replaced by the new change of the extension — and cannot be redone. A typical bug, not expected behavior.

If this is not reproducible after disabling the extension and restarting SketchUp, it’s likely caused by the extension. Let’s see if the new version of Layers Organizer resolves this.


#7

Its’ not the Layers Organizer.
I disabled it, then exited SU, restarted it on a brand new model. I moved Stacy, undid the move and attempted to redo my move, but the option was grayed out. Can’t get much simpler than that! I also checked to be sure Layers Organizer was turned off in the extension manager. It was.

I don’t see anything in SU preferences to turn on/off redo.

What to (re)do?


#8

are you trying Edit >> Undo Move, Edit >> Redo Move

does ⌘Z and ⌘⇧Z work for Undo/Redo ?

or are you using File >> Revert ?

john


#9

The former.
⌘⇧Z doesn’t work is not an option in the menu either.
⌘Z does work both ways.
But it’s pretty annoying not to be able to redo what you’ve undone!


#10

check in Window >> RubyConsole if these work…

  Sketchup.send_action('editUndo:')  ## Undo  ### ⌘Z

  Sketchup.send_action('editRedo:')  ## Redo  ### ⇧⌘Z

copy/paste then enter, one line at a time…

john


#11

Uh, that’s interesting. My Ruby console doesn’t work either. Not when I try to copy/paste and not even to type into. I’ve never used Ruby before so I can’t tell if it’s always been like that or is new to SU 2018.

OK, two bugs now…


#12

did you enter in the bottom text field, not the large top one…

john


#13

the other place to try is by adding them to your Custom Toolbar…


#14

I can’t enter anything. It won’t let me type in the dialog box:


#15

RC should gain focus when you open it or whenever you click in the input field…

in the gif I use the wrong command first, but it should give you the idea of how it works…

if it doesn’t take focus, I would suspect you have something wrong with your SU install…

john


#16

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.