I've lost the Edit/Redo function in SU Pro 2017

Maybe it’s a result of upgrading from El Capitan to Sierra, but since about the time I did that, I’ve lost the option to Redo a change. Undo works as normal, but I’ve noticed that Redo is now apparently permanently greyed out.

I thought at first it was because I was working in a very large (260MB, 22.6 million edges, 300,000 components after simplfication) SU model, but now I see it is greyed out for all models, including small ones.

And persists even after restarting SU since working on the large model.

Anyone else have this problem? Any known causes?

PS. Command + Shift + Z is the default shortcut in SU on Mac for Redo, and Command + Z for Undo. The latter works, the former doesn’t.

When I press Command + Shift + Z , I get the same as Shift + Z which is set in my SU Preferences to Zoom Extents. Even if I disable that shortcut, Redo, or Command + Shift + Z is still not available.

did you try a full power recycle?


I did that for other reasons a couple of days ago. Will try again tomorrow, though, and see if it makes any difference.

Cold reboot makes no difference - Redo still greyed out.

I just tested Redo on my MBP with SU2017. It works as expected. Try this:

Get the Line tool and draw a line.
Hit Command-Z to undo the line.
Hit Shift-Command-Z to redo the line.

Redo is only available immediately after Undo.

I know - have tried that several times (with Rectangle tool rather than Line tool). Redo just stays greyed out and Command + Shift + Z does nothing (or does Zoom Extents).

Just confirmed again with Line tool - still no Redo after Undo. I did get the option to Undo Layers Organizer in a new drawing, so tried disabling Layers Organizer, restarted SU, and there’s still no Redo after Undo.

But it does make me wonder if some other plugin is interfering? Will try disabling all and see if that makes a difference.

do you have the ‘Standard’ toolbar on Mac that gives the the undo and redo icons, worth checking if the redo function is working with the icon to see if it is shortcut related.

on a mac, you can add them to the Custom Toolbar, but they don’t show anywhere by default…


Just tried disabling all plugins, and I’ve got Redo back. So it’s something in a Plugin that is stopping Redo working. Will add them back half at a time to try to track it down.

It seems it’s Layers Organizer that stops Redo working. I’ll get in touch with the authors and see if I can get them to fix it.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.