Disable Autosave for Sketchup Free

Is there a way to Disable Autosave for Sketchup Free? Apparently other similar topics have been closed and supposedly fixed, but my model saves every 30 seconds or so, bringing my work to a halt for about the same length of time while it saves. There’s also a period of 10 seconds or so before the Save begins that locks up the program. So 40 seconds of every minute of work is wasted waiting for the model to save.
I’ve tried opening another model and then reopening the one I’m working on, in an attempt to reset the Save, no luck. This is incredibly annoying, especially for something that was supposed to be fixed.

2 Likes

As you say this has been brought up multiple times but to my knowledge it has never been implemented as a user preference. The only thing I can do is recommend the desktop version instead, that not only has a user setting for disabling auto saves but also doesn’t have to send the model over the internet when saving.

Is there a free desktop version?

SketchUp 2017 Make is still available for hobby use.

1 Like