Dimensions of lines as you draw

When I draw say a rectangle, can i see the dimensions as i draw,
I’ve spent hours trying to draw a simple 22m x 7m rectangle but finding it almost impossible!

i draw a line, (no idea how long it is,until i measure it and it says 93000mm
but i want to have a line from one of the screen to the other thats 22000mm
If i scale it my model ends up a tiny rectangle in the middle of the page
How can I draw rectangles and see what size they are as i draw, usefull designing rooms etc in a house.
Surely something as simple as this is doable but I can’t find how?

Please help

It’s in the measurement window bottom right of the screen.

just type in the number:

  • click the rectangle tool,
  • click the start point
  • type “22m,7m” or “22000,7000”
  • hit [return]

Note: you don’t click anything between these steps - you can move the mouse, but if you click then you are either selecting another tool/menu item/window or placing down the end point.
The numbers you type in will be displayed in the lower right corner unless you have the dimensions toolbar active and have moved it somewhere else on the screen.

1 Like

Creating the entire rectangle by clicking start endpoint and second endpoint (the diagonal) is also possible. You can still enter new desired measurements.

1 Like


I also seem to have a problem with this.
If I create a rectangle and try type in my dimension sizes, it does not follow my values.

If I try do a 10x20 rectangle, it moves, but not to the correct measurements.
I start my shape by clicking and moving diagonally,
let go of the click,
type in the dimensions ie: 10’,20’
and press enter.

The shape does not change according to what I had typed.
Sometimes only the x-axis of my rectangle would adjust (to a random value) and sometimes only the y-axis.

I thought it was maybe my beginning points or the order of my values but I’ve tried tons of different
theories eg: 20’,10’ or swapping my X & Y of my shape with different beginning and end points and it still makes a random rectangle, sometimes a square.
Sometimes my shape would even go into the -x & -y areas.

I have even tried re-installing Sketchup to no avail.

Please help as I really need assistance and has been bugging me for a while.
Thank you in advanced!:slightly_smiling:

did you try



Faceplant no way -_-.

Thank you so much!!! :smiley:
You really are a sage!!!:grin:

But can I ask: why is it ; instead of , ?

your keyboard preferences are set to use the


as a decimal seperator instead of


you may be able to change that, I can on my mac…


Thank you so much!!
I feel like such a noob:joy:

John T
Click to start the rectangle but do not hold the button down, type in your dimensions separated by a comma, done.

Comma’s work on English US input keyboards but not on some others, that was the issue here…


Because in many non-US-English countries both the comma and period are already “taken”, with the comma used as the decimal separator and the period as the thousands separator.


@Anssi, for future reference, can you change it easily on a PC?


It seems that it is not too difficult to change, but it would affect all applications and make your peers perceive you as a moron. I’ll have to test if changing the separators affects SketchUp’s behavior or if is dependent on deeper things. Some other applications, like AutoCad, happily ignore all the regional settings.