Dimensions mirrored

When I open any of my files now, the dimensions are mirrored vertically. Any new ones I draw exhibit the same behavior

I know this is a normal win fix for some oddities, but have you tried rebooting your mac.

Yeah I’ve tried a reboot, still the same issue. Drawing new dimensions in a new model are also equally affected.

It’s very odd, never heard of this happening before.

Perhaps @colin can ask around the office about it.

By any chance did you make 4 copies of a componentand it is mirroring inside them?

Nope, I can create a brand new file draw a line, dimension that line and the dimensions are inverted.

Can you share an example file with the reversed dimensions so we can see what we get n our end?

I’d be surprised if it does, because everything on my side is impacted, new and old. But here we go.

jpbathroom copy.skp (146.1 KB)

Well, the dimensions do look fine here.

It looks to me as if this is a graphics driver issue but I’m not sure how much control you have over the graphics drivers with Mac.

Yeah, very little honestly.

If I open it up in the browser based sketchup it looks fine.

Weird. Long, long shot but I wonder if reinstalling Sketchup would changing anything. I doubt it but like chicken soup, it couldn’t hurt.

Nope, just cleared everything and reinstalled 2017 fresh, still the same issue. Super odd.

What is MacOS 11 ? Is it a beta?

Good question. I was assuming 10.11 but probably incorrectly on my part.

Yeah it’s the Big Sur beta. Maybe that’s it. I don’t have another OS copy on this affected machine to check though =\

Ah ha! So the penny drops. I guess unless Apple fixes it, you are kind of stuck with reading your dimensions in a mirror.

I don’t know almost anything about current Macs, but reading about the symptoms and that they haven’t appeared but recently, makes me suspect that something OS related has changed lately. Googling, I saw that someone had seen this happen with Excel and Word, but I saw no obvious solutions.

1 Like

Maybe @colin might have a clue…

Wait…someone runs a beta version of an OS and is surprised to find a bug?