Dimensions in Layout > DWG messed up

I have Exported a LO 2024 page to DWG and end up with a mixed bag of dimensions e.g. some are shown correctly and others transform to their paper space equivalent e.g. 100mm changes to show 2mm (at 1:50). Layout displays and exports to PDF OK. Any suggestions as to what operator error may be at play here?

I tried the same thing LO 2023 and got the same results so I assume it isn’t a bug.

Check this option while exporting… (sorry my SketchUp is in Spanish)

This is probably the best option but note that it results in a file that is to LayOut page scale so to get to full scale you have to scale the drawing back up in AutoCad or your other DWG editor.

Thank you for the suggestions. I finally pinned it down to the dimension drawing scale setting. Despite using Auto Scale, the dimensions that are showing incorrect in the DWG have an inactive value of 1:1 rather than 1:50. The output to DWG appears to be using the inactive value on output, not the placed drawing scale. I need to go and check why I ended up with the 1:1 values. For now it looks like I might need to turn off Auto Scale before exporting.

Screenshot 2024-06-24 at 22.29.43

What you show in the Dimension Style panel indicates that the dimensions would auto scale to the SketchUp viewport. They’ll pick up the scale from the scale you’ve set for the SketchUp viewports. That option has nothing to do with exporting .dwg or .dxf files.

You are right @DaveR, even if I turn off Auto Scale I get the error, but it is the only indicator that makes sense. Dims that are showing correctly at 1:50 with an inactive scale of 1:1 are output to DWG at 1:1. Those that have an inactive scale of 1:50 are output correctly to the DWG file.

The frustration now is I can’t seem to clear the 1:1 without re-creating the offending dimensions.

Does the viewport have a scale of 1:50? Is there even a viewport?

You could select the dimensions and then turn off Auto Scale in the Dimensions panel and set the scale to 1:50. Still, you should not need to do that and if your model was created at real world dimensions, leaving Auto Scale for the dimensions should work just fine. What you describe implies something is incorrect about the way you set up the LayOut file in the first place.

It’s only a problem with Export to DWG. Everything in LO is correct. I’ll just delete the offending values and re-create them. I was hoping I might have missed a simple setting with an easy fix. It’s not a disaster there aren’t that many dimensions to fix.

I’m pretty sure the problem originates from storing Dim Styles in the Scrapbook. If I sample the style or drag a copy into LO it sets the inactive scale to the 1:1 value.

Thanks for your suggestions.