Dimensioning won't snap onto model internal walls Layout

Hi,

I am using SketchUp Pro and trying to get plan sorted for submission to clients, I have noticed the dimension tool isn’t snapping onto any of my internal walls properly within Layout? it seems to work with the external wall and windows just not the internals (ALL internal walls are meant to be 110mm wide? any reason why?

[Copy of floor plans ]

I have created all of my sections in SketchUp model though the section tool. I have uploaded plans (Mainly floor plans are the problem.

Any help would be great.

I suspect what you are trying to do is dimension the section cut lines like this.
dims
In LO2018 and earlier dimensions won’t snap to section cut lines, though. That was changed in LO2019.

Short of upgrading which you probably don’t want to do in the middle of a project, you could create a Group from slice (right click on the section plane) to create actual geometry for the Dimension tool to snap to.

Hi Dave,

Thanks for your quick reply, yep that’s exactly what I’m trying to do :sob:,

If I upgrade will I just be able to open this file in 2019 and it will then click on each wall (the externals all seem to be working at the moment, it only starts playing up with the internal walls of home eg. dimensioning the bathroom / powder room etc.

If I was to stay with this one, I am not too sure what you are meaning by group from slice? would that just mean go to the section of floor plan, right click and make group (would you include the section within this?)

Thanks for your help

Yes. You should be able to open it in LO2019. I did here.

As for Create Group from slice, this is a SketchUp thing. Make the section plane visible (Section 43 seems to be the right one here.), right click on it and you should see it in the Context menu.

When you do that, you’ll get the outlines of the plan. I’ve moved it up and turned off the section cuts so the group can be seen.

Sometimes it can be helpful to use the group from slice anyway. You can create a scene showing only the group from slice and nothing more. Stack viewports in LO with that one above the model. The group from slice will generally be simpler and make it easier to ensure you are dimensioning the right things.

1 Like

Hi Dave,

I can’t thank you enough for that little trick, I had absolutely no idea about and it has worked a treat! I only ever really need that one for plan views as Elevations etc seem to work great, it will be a awesome new addition until I start a new project on 2019.

Thanks once again, Have a great weekend! :grinning:

Glad that helps. You have a great weekend, too.

Hi @DaveR

I saw your post and upgraded to 2019 and still some internal walls do not snap.

Is there something I should be aware of?

Not enough information so it’s hard to tell what you are having a problem dimensioning.

Will send you the file tomorrow if you wouldnt mind taking a look at it.

Turns out some of the geometry edges were hidden and that was causing the problem.

We didnt realize as it was still rendering the solid fill.

Ahh… Yes. It’s difficult to get dimensions to snap to hidden geometry. If it needs to be hidden, hide it after dimensioning.