Dimensioning out-of-plane lines

I am drawing a blank here, folks (no pun intended). I can’t seem to accurately dimension lines that are off axis.

Picture a pyramid. It is 14" high, that is, a vertical line drawn from its tip down to the point where it intersects the horizontal base at a 90 deg angle is 14" long.

The edges of the pyramid, however, measure 17" from tip to base, because the sides of the pyramid are angled. Sure enough, if I click one such edge, the Length field in the Entity Info box accurately displays 17".

But I cannot create a dimension that displays the actual 17" length of that edge. The dimension tool insists on a 14" dimension that references the vertical plane. I went over the online tutorials and I could not find a solution related to Sketchup (apparently in Layout you can press Alt to do just that). What am I missing?? Thanks!

I have noticed sometimes under certain circumstances dimensioning off plane is easier if the item is opened for editing. Why that matters I do not know.

I tried with the component open or closed, it behaves the same way.

You could try like this:

  1. Press “Shift” key and then “Dimensions”


If the ‘Dimension’ tool insists on not pulling the dimension out according to the edge’s real length, you may need to change the view angle. Can be tough but sometimes this helps.

Otherwise your edge needs to be in a plane with at least one of the three axis, @mihai’s third solution.
Most ofthen the edge is an edge of a face. An easier solution than rotating the model is to temporarily use ‘Align Axes’ in the context menu of that face. This instantly gives you the right plane and makes correct dimensioning much easier. (in the end use ‘Reset Axes’).
If the ‘Align Axes’ option still is not enough, you can always force one axis being on the edge (or whatever two vertices) you want to dimension. Use the (draw new drawing) ‘Axes’ tool to draw the Red axis on the edge. The other two axes don’t matter. (in the end use ‘Reset Axes’).
It all takes only a few extra clicks with 100% guaranted solution.

p.s. the ‘tripple click’ solution on the an edge doesn’t seem to work properly in SketchUp free (web version), unlike in the desktop version.

@g.h.hubers thank you. The Align Axes trick works. Other suggestions did not pan out on my system (I’m running Pro on Windows 10).

You do have to realign axes to each face that you need to pull dimensions off of, and each dimension line that you create in this manner aligns to the plane it’s pulled from, so that soon you have dimension lines poking out every which way. My model is complex, so the 2D takeoffs look… interesting :slight_smile: (I used a pyramid as an example for simplicity’s sake).

A built-in command to do this would be great. Like, say, if pressing Ctrl when the Dimension tool is selected constricted it to the selected edge?

I tried triple-clicking on an edge in a component open for editing. It selected the entire component.

1 Like

I meant “tripple click” not with the selection tool but with the dimension tool. It’s no guarantee though.

How would a built-in command work? It could only give you the desired dimension somehow aligned to the view (your current screen plane). In that case you end up with even more unpredicted “poking out” dimensions. An edge is a one dimensional entity.
After creating a dimension you can rotate it, using the edge as the rotation axis. Use the rotate tool and drag it along the edge to get its direction for rotating the selected dimension. Just like rotating other things. So you can “adjust the poking”.

You can also, once placed, move the dimension towards or away from the edge in the dimension entity plane (i.e. slide it along its leading lines).

For all I know the “tripple click” method (maybe even after aligning the axes to the face) produces a dimension close to or even (visually) on top of the edge, so without visual leading lines.