Diagonal Dimensions


#1

I am trying to place a diagonal dimension that is in the red-green plane with the dimension tool. One time I was able to move the cursor until that option displayed. However, I have been trying on another diagonal and I have not found how to move the cursor to escape the on axis dimension. How do I get the dimension to measure the diagonal and not the red or green direction.

I have been having trouble uploading screen saves. I get the message that it is over 5kb limit. I did not have this problem before. Has something changed?

Thanks
Eli


#2

Getting a diagonal dimension is possible but somewhat fussy. You have to move the cursor away from an endpoint of the dimension in a direction that causes the inference engine to understand that you want the diagonal. I can’t state an exact process, as I don’t know of one - I just fiddle about and eventually find a direction that works.

Regarding the upload issue, it is happening to everyone and we’ve been complaining about it for several days. So far there has been no explanation as to what changed.


#3

With the dimension tool, use inference to go from anywhere to anywhere else, at any angle. But then do a double click. If you single click it will start to lock onto the nearest axis.


#4

Just select the diagonal edge and with the Dimension tool pull the dimension straight out.

-Gully


#5

Gully, how did you persuade Discourse to upload that image? I’ve been getting the 5K limit error on every image I have tried for several days now…


#6

Sort of a pita, but it’s what we had to do on the Google forum. Just upload the image to a photo server (I’m using Picasaweb) and paste the url in the post.

-Gully


#7

If you click the endpoints of an edge the dimension is pretty much locked to that axis. But if you click the diagonals it can move to all axes.


#8

Screen saves appear to have come back. The double click is working to gain access to diagonal. However, look at this screen save. I am able to locate a diagonal that is not aligned with any of the axis by drawing lines that are on axis to control the endpoints. You see the 9’8 3/8" dim is on the blue green axis, not the line length itself. However, when I drew a line to connect to that line, also not on green blue plane, it did give the line length.


When I move the green aligned line defining the 9’3 3/16" diagonal which is on the red green plane, in the blue direction, it will not give me the line length. 2nd screen save. However, if I move the line not in the a red, blue or green direction, it gives me the line length. Third screen save.

Sketchup seems to struggle when a line is being drawn that is not aligned with the default planes. Any tips will be appreciated.

Is it possible to temporirly change the default planes that could be switched back after an action?


#9

I’m not really understanding much of what you are saying, perhaps if you upload the model we can see what is going on.


#10

Like Box, I also don’t understand what you are saying.

But in general: if you need to measure the distance point to point without any line between them, temporarily change the drawing axes, one (say red) running through both these endpoints.
The ‘Dimension’ tool temporarily will align to the red axis, enabling you to set up the correct dimension. Then reset the axes (right click on an axis in empty space > select ‘Reset’)


#11

I found for the first time the tool for adjusting the axis. Dimension easily followed the previously off access line. That worked. Right click on one of lines while alignment tool is active gives access to reset button. Thanks again.

Eli