Dimension Tool measurement depends on view


#1

The attached image shows a group from a section cut

.

When the selected left view in Parallel Projection is selected, the dimension given is 6875 mm but when te Parallel projection/Iso view is selected, the dimension is given as 6963 mm, which is correct.

As can be seen, in the first view, the dimension tool somehow takes an out of plane path between the two points.

I’ve also attached the sketchup file (that just includes the group made from the section cut) that shows this behaviour.
Dimension problem.skp (99.8 KB)
After much playing around with views, axes etc, I’m still no closer haven’t been able to control this behaviour, I’m no closer to understanding or controlling this behaviour, so any help would be much appreciated.


Meta: Community posts always start in the middle of the comments, not at the top (Firefox)
#2

Your section isn’t parallel to the global axis (reset axis to see this), so you have two options for the direction: perpendicular to your cut or in the global axis direction (-> your two different values), see this screencast…

https://www.screenr.com/N1zN


#3

Thanks for the quick reply. I’llgo back to the original model and try to align the section


#4

:+1:

Top View > Parallel Projection > Axes Reset


@joenext15
You’ll find modeling easier with a Style that renders the Axes, Ground and Sky.
Then create a Scene with whatever style you need for presentation, printing, etc.


#5

Just to add to the others, you need to keep in mind that the dimension tool is working in 3 dimensions also. So you need to be aware of what you are measuring and which points you decide to fix the dimension to.
As you see here, selecting the two corners allows me 3 possible choices.


#6

Thanks very much for all your responses. Aligning the house in the model to the global axes and then making the section cut has done the job, so I’m back on track to progress our building plans.

But I’m still confused: Originally, the house was not aligned with the global axes, as I’d geo-located the house site and rotated the house to face north. But before I did the section cut, I aligned (or at least thought I did) the global axes to the house so that the section cut would indeed be perpendicular to the re-positioned axes.

So, am I misunderstanding global axes and how to reposition them, Or do I have to align the orientation of whatever object I wan to section? Surely not the latter, as I have a planned shed that is at an angle to the house and having to rotate the model again to the default global axes to section the shed would be a pain.

I hope my questions make sense. It’s 3 am in my part of the world and the mind is not all that sharp at the moment …


#7

It’s not clear why you would create a section of the building by aligning the section plane to the axes.
Why not align the section plane to the building?

When you hover the Section tool over a face, notice the Section Plane auto-aligns with that face.

However, if you move the Section Tool away from any geometry into free space you’ll find that
it auto-aligns with the Drawing Axes … not the Global Axes.

• The Global Axes are inalterable.
• The Drawing Axes are merely adjustable drawing guides.
They’re aligned with the Global Axes by default, but you can position and orient them any odd way you wish.

Right context click on any Drawing Axis. (Do this away from any geometry)
In the context menu that appears:
Reset returns the Drawing Axes to their default position, aligned with the Global Axes.


#8

Thanks for clarifying the distinction between global and drawing axes, Geo - it is now clear to me.

But I did originally create the section as recommended - ie auto align on the face of the building, hold the shift key to lock the alignment and move to the place I wanted the section cut.

I’ve repeated this in a stripped down version of the full model and get exactly the same problem again, and I’ve attached the stripped model.Test.skp (299.2 KB)

This issue doesn’t overly concern me in Sketchup as I don’t normally use its dimension tool - the big issue for me is that when I send the model to Layout, I can’t get the dimensions right on the plan.

I must be doing something wrong but I can’t see what it is.


#9

SU is a fulltime 3D environment.
Everything in that environment is defined by an inalterable 3-axis Cartesian coordinate system.
It cannot be turned off nor will ignoring it make its influence go away.

The adjustable drawing axes are supplemental.
In general terms, they steer the tools; which is rather handy in off-axes modeling situations.

Best practice is to employ axial inference to your advantage rather than struggle against it.
• Begin modeling at the Origin, the drawing axes in their default position aligned with the global axes.
• If the model is rectilinear, then build it on-axes.
• Reposition the drawing axes for off-axes portions of the model, then put them back to default.

You say the reason for the rotating the model some 9.1° off-axes was to accommodate geo-location.
Rotating the model off-axes simply isn’t the solution; it’s the root of the problem.

You haven’t described how you geo-located the model.
• Add Location?
• Manual Geo-location?

Neither have you explained your reason for geo-locating the model.
• Is it only for shadow study?
• Is it to add the Google Earth terrain to the model?

Tell us a bit more about what you want to create and we’ll be able to explain how.


#10

Sorry if my posts have been unclear - hopefully it’ll help if I back up a bit:

I have been building a model in Sketchup for the construction of a new house, with the intention of then sending the model to Layout to generate 2-D plans to submit to the local council for approval to start building.

I did begin the model at the origin and on-axes but with the house not being aligned with any of the land boundaries ( in order for the house to face north), none of the boundaries meeting at 90 degrees and also having a shed also unaligned to both house and boundaries because of land slope consideratons, it didn’t take long for components to be built with axes being moved around (and then left as is and not repositioned).

Geo-location was done through the Add Location feature in order to look at how shadows played out throughout the year and so figure out a good width for the eaves and particularly the verge on the west side of the building.

Everything seemed ok - I set up my section cuts and scenes, (checking everything with the SU tape measure rather than the dimension tool), sent the model to Layout and started dimensioning the 2-D plans.

This is when I hit trouble, with the unexpected dimensions reported by layout on the section cut I attached in my first post. After much investigation, I discovered the the problem wasn’t in Layout, as I found how to reproduce the effect in SU with its dimension tool.

Through the discussion in this thread, I’ve come to some appreciation of the characteristics and importance of the global axes. But SU/Layout behavious still seems odd to me. After all, drawing axes can be moved around to facilitate the building of components and surely dimensioning will normally be required relative to those axes. And isn’t layout there to specifically generate 2-D documents from specific viewpoints and why doesn’t it respect dimensioning perpendicular to the view?

I must still be missing something. Any advice on how to straighten out my thinking and how to fix my model to generate accurate 2-D plans would be much appreciated.


#11

Axes location/orientation is a saved property of a Scene.
When in use the Dimension tool infers to geometry and Axes orientation.

Look closely at the second file you shared titled: Test.skp
Specifically, examine the scene named: Section
• The Axes location saved with the Scene is the default alignment with the global axes.
• The section geometry is not aligned with the axes saved with the Scene. It’s 9.1° off-axes

• The Camera location saved with the Scene is not orthogonal to the geometry.
• Instead, the camera is aligned with the x axis … Camera Standard Views > Left … aka Azimuth 90.0°

The scene titled ‘Section’ is an oblique 80.9° view of the section geometry which cannot be printed to scale.


Section Scene as Saved


Section Scene as Saved w/ Layer ‘Trusses’ visible


Correct Orthogonal View
Updated… a R-L crossing selection reveals two section planes.

Use the Axes tool.

• Set the red axis along a horizontal edge of the section geometry; green pointing up; blue horizontal leading toward the desired camera position.
• Then apply the dimensioning.
• Then, right context click on any axis > Align View
The camera moves to the blue axis pointing at the drawing axes origin … orthogonal view.
Set the camera to parallel projection and proceed with creating the scene.


#12

I think the penny’s finally dropped and everything you’ve said now makes complete sense to me.

Clearly, I’ve been operating with a number of misconceptions about axes, scenes and dimensioning and have paid for it by spending many hours going around in circles.

I think, with this new found understanding, that I can now proceed to generate the required plans.

Many thanks to all members who replied to my posts - particularly Geo, who’s been very patient with me. You’ve doubtless saved me many more hours of work and anxiety!