Dimension lines moved with my component


#1

Using Sketchup 2018, climbing the learning curve, created great bar, made it a component, dimensioned it in parallel perspective, placed dimensions in a dimension layer and turned that layer off before dragging a copy of the bar onto my floorplan - - - now I have dimension lined connecting the copy to the original bar? What do I need to do to fix this mess?


#2

It does look a mess. Can you upload the SKP file so we can see exactly what you’ve got?


#3

I tried to upload the skp file but it was too large, I just put it on my Google Drive and provided a link

https://drive.google.com/open?id=1XbcNEpvY4Ft-275DPFKeuNFTP3oS5gbS


#4

It looks to me as if you wound up selecting more than just the bar to copy. I think at this point, though, the easiest thing to do is delete all the dimensions and start over. It’s important to understand that layers don’t create separation between entities and they don’t prevent entities from being selected or moved.

Incidentally you are not using layers correctly here. You want to leave Layer 0 active at all times and keep ALL geometry (edges and faces) on Layer 0 and only move components and groups to other layers. You need to also get in the habit of using groups and components.

You also want to make sure you’re keeping up with correct face orientation. All of the exposed blue faces in your model need to be reversed.

Are you hoping to create a construction plan for the bar from this SketchUp model?


#5

Thanks for your help - - I was advised via U-Tube to put dimensions in a layer so I could turn them off - Is there a way to dimension objects for my construction without having the dimensions appear in my model floorplan?


#6

Putting dimensions on a separate layer is a good idea but that only allows you to control their visibility. It doesn’t separate them from the rest of the model.

Since you are using SketchUp Pro 2018, you might consider doing the dimensioning in LayOut instead. You’ll want to use LayOut to create your plans for building the bar.


#7

How about I create the object, make it a component, copy the component and then save it with a new name like bar-dimensioned. Then I assume I could edit bar-dimensioned to add dimensions and save that it a separate layer. Then put the un-dimensioned bar in my floorplan- - - or must I always keep dimensions in layer 0?


#8

That is making it more difficult, I suppose. As sad, keep your ‘raw’ geometry on Layer0. (Edges and faces)
You can have the dimensions attached to a different layer. There is no need to have two components, just toggle the visibility of the dimension Layer. A component is nothing but a ‘wrapper’ that prevents the geometry and dimensions from ‘sticking’ to other (raw) edges and faces in your model.
If fi you’d have a table which consist of four legs and a table top, the container ‘table’ could have four ‘leg’-components on Layer ‘LEGS’ and one tabletop - group on Layer ‘TOP’ all wrapped in the higher-level component ‘Table’ (=container) Which could be assigned to Layer ‘Table’
All edges and faces would still reside on Layer0, though…


#9

As Mike said, that’s a lot of work. It sounds like you still haven’t got the layer thing, too.


I redrew your bar from scratch making components of the individual parts. Your model of the bar is to the right. The dimensions are on a Dimensions layer while the components are on other layers. If you need to make a copy of the bar, you can turn off the Dimensions layer to make it easier to select the components. Then use Move/Copy to make the copy.

No need to change the name of the bar. If you need to make changes to it, you would want to leave the copies related to each other anyway.

As I was working with your model more I figured out that your screwed up dimensions were anchored to geometry that you didn’t copy because those edges were on layers that were turned off at the time. It comes down to improper use of layers.


#10

I thought that is what I did - - - I believe you later comment “I figured out that your screwed up dimensions were anchored to geometry that you didn’t copy because those edges were on layers that were turned off at the time.” is the root cause of my difficulties.

Thanks for all of your efforts!

I have noticed several times that when I turned off a layer that there would still be something from the object in my model - - note that I have been modifying components by exploding them, rather than editing the component, which probably allowed the exploded component geometry to stick to other surfaces. Any comments on this?


#11

Any comments? Absolutely!

First, you’re creating the layer problems by exploding components to work on them instead of just opening them to edit mode. When you explode the component, the contents take the component’s layer assignment. There are some places that is very powerful however it’s a gotcha when you are working as you were working. If you do explode a component to do work on it, you need to immediately change the geometry’s layer to Layer 0. The geometry will be selected immediately after Explode completes so changing the layer association wouldn’t be hard.

Exploding the component can cause the geometry to combine with other loose edges and faces which can be a problem (your model exhibits that, too.) In addition, exploding the component to work on it eliminates one of the powerful benefits of components. If you edit the component instead, all other instances of the component will get the same editing. Exploding to work on it just creates more work for you.


#12

Thanks again, if you turn on all the layers you will see the man-cave I am designing for my basement- - -this is my first project with sketchup so it has been hard to advance without a mentor, other than the videos on U-Tube. None of them helped me understand the problem I faced- - thanks a million!


#13

I did look and see the rest of your man cave. I’d like everything about it except having my back to the fireplace while playing the video game. :wink:

Maybe we could chat after I get back from walking the dog.


#14

Trying to clean some issues with this model based on your observations/recommendations- - - I turned off visibility of all layers except the “walls central & stairwell” layer which I had just created and then I created a “Walls Central & Staircase” group - - - easy peazzy

However, because of sticking geometry from my non-componentized block wall I can see under outliner that the group is associated in the group “Walls Central & Staircase” . Is there a way for me to put the block walls in their own group and remove them from the “walls central & stairwell” group now that their geometries have merged? Or is this just a lesson learned to use components and groups for everything?

Secondly would you ever draw anything then, without putting it in a group or component?

Thanks!


#15

Ben, I’ll give you more of an answer when I get home from the dentist. To your last question, though, no I never leave loose geometry.


#16

been researching re-parenting, loose geometries —what a mess without component protection - - - I’m getting there and undoing the mess is a great learning opportunity - - good luck at the dentist


#17

Instead of repairing your model, I would be inclined to redraw from scratch using proper methods to create components/groups and put them on layers correctly. I would move the entire existing model back along the green axis so it’s out of the way so you can use it as a reference where appropriate. As much as that sounds like a lot of work, I think it’ll be a whole lot more straightforward and less prone to error than repairing the existing model.


#18

I hear you, but I have only been using sketchup about 1 month and with my current skillset that would take me considerable time; probably a full day or more. I believe this model will serve its purpose; but I appreciate your help. I learned much with our interaction.


#19

Do you mean to make certain that layer 0 is the active layer, or to go to the Entity Info area and switch the layer selection to 0 there?

When I do use edit component to modify stuff I can not see the guidelines as I draw them- - - why , am I doing something wrong?


#20

Layer 0 should always be active even if you explode a component. The contents of the component will assume the component’s layer when the component gets exploded. If the component is on a layer other than Layer 0, you need to go into Entity Info and set the layer association back to Layer 0. It’s easiest to do that immediately after exploding the component because the contents of the component container will be selected already.

If you have set things so the rest of the model is hidden when a component is open for editing, you won’t be able to see guidelines or other entities. You can change that under Window>Model Info>Components. Untick the boxes.