Dimension leader or label leader disappears behind the default layer window

I can not seem to figure out why the leader line disappears behind the default layer when moving dimensions to a different layer or drawing them on a different layer other than default. I have tried bring to front and it does not work. Any suggestions?

Screenshot 2022-09-21 085617

That typically happens when you put the label on a layer lower in the list of layers. Put the label on a layer above the layer the viewport is on.

Bring to front only works for things on the same layer.

1 Like

Thank you Dave!

1 Like

You’re quite welcome. For what it’s worth, here’s the layers list from one of my templates. Labels go on the Art Text layer and, of course dimensions on the Dimensions layer. Viewports from the SketchUp model go on the Model layers. There are multiple Model layers because I frequently stack viewports. The last three layers in the list are for page borders and title block stuff.
Screenshot - 9_21_2022 , 8_24_05 AM

This is extremely helpful as I am a veteran AutoCAD user (since version 9) and used to using a layer structure like this!

1 Like

Good deal. Just remember that in SketchUp, tags are not like Layers in AutoCAD.

Got it!

1 Like

Yes they are! (except that AutoCad has more layer lock/display options)

Except that tags don’t provide any separation of geometry and tag order has nothing to do with what appears in front of what.

Layers in AutoCad don’t separate geometry either. By default, all geometry is separate, and if you use constraints to stick things together, they operate independently of layers. And the order of layers doesn’t affect the visual stacking order. Layers are ordered alphabetically.